Closed Bug 1503687 Opened Last year Closed 11 months ago

Intermittent AttributeError: 'NoneType' object has no attribute 'pid'

Categories

(Testing :: XPCShell Harness, defect, P5)

defect

Tracking

(firefox-esr60 fixed, firefox64 fixed, firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- fixed
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: gbrown)

Details

(Keywords: intermittent-failure, Whiteboard: [necko-triaged])

Attachments

(1 file)

Filed by: cbrindusan [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=208957553&repo=mozilla-central

https://queue.taskcluster.net/v1/task/WJ33xW--T7iXCXiNhQvw1w/runs/0/artifacts/public/logs/live_backing.log

11:14:23     INFO -  TEST-START | netwerk/test/unit/test_bug468594.js
11:14:46     INFO -  TEST-TIMEOUT | netwerk/test/httpserver/test/test_start_stop.js | took 300001ms
11:14:46     INFO -  xpcshell return code: None
11:14:46     INFO -  netwerk/test/httpserver/test/test_start_stop.js | Process still running after test!
11:14:46     INFO -  TEST-TIMEOUT | netwerk/test/unit/test_nsIBufferedOutputStream_writeFrom_block.js | took 300002ms
11:14:46     INFO -  Exception in thread Thread-4742:
11:14:46     INFO -  Traceback (most recent call last):
11:14:46     INFO -    File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py", line 810, in __bootstrap_inner
11:14:46     INFO -      self.run()
11:14:46     INFO -    File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py", line 1082, in run
11:14:46     INFO -      self.function(*self.args, **self.kwargs)
11:14:46     INFO -    File "/Users/cltbld/tasks/task_1541008504/build/tests/xpcshell/runxpcshelltests.py", line 678, in <lambda>
11:14:46     INFO -      testTimer = Timer(testTimeoutInterval, lambda: self.testTimeout(proc))
11:14:46     INFO -    File "/Users/cltbld/tasks/task_1541008504/build/tests/xpcshell/runxpcshelltests.py", line 330, in testTimeout
11:14:46     INFO -      self.killTimeout(proc)
11:14:46     INFO -    File "/Users/cltbld/tasks/task_1541008504/build/tests/xpcshell/runxpcshelltests.py", line 287, in killTimeout
11:14:46     INFO -      mozcrash.kill_and_get_minidump(proc.pid, self.tempDir, utility_path=self.utility_path)
11:14:46     INFO -  AttributeError: 'NoneType' object has no attribute 'pid'
11:14:46     INFO -  netwerk/test/httpserver/test/test_start_stop.js failed or timed out, will retry.
11:14:46     INFO -  netwerk/test/unit/test_nsIBufferedOutputStream_writeFrom_block.js failed or timed out, will retry.
Whiteboard: [necko-triaged]
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1411358
Seems like something the xpcshell harness should avoid.
Assignee: nobody → gbrown
Status: RESOLVED → REOPENED
Component: Networking → XPCShell Harness
Product: Core → Testing
Resolution: DUPLICATE → ---
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8352f46310c7
Avoid python attribute errors for some infrequent xpcshell timeouts; r=jmaher
https://hg.mozilla.org/mozilla-central/rev/8352f46310c7
Status: REOPENED → RESOLVED
Closed: Last year11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.