Closed Bug 1503727 Opened 11 months ago Closed 11 months ago

Lightning manifest should specify strict_max_version

Categories

(Calendar :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: darktrojan, Assigned: darktrojan)

Details

Attachments

(1 file)

We used to specify a max version, for good reasons. When we changed manifest formats, the max version wasn't added, I didn't think it was possible at the time.

It's possible to install Lightning 6.5 (instead of 6.6) in Thunderbird 64.0b1. It doesn't end well, but it's possible, and it shouldn't be.
Attachment #9021691 - Flags: review?(philipp)
Attachment #9021691 - Flags: review?(philipp) → review+
Keywords: checkin-needed
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/0da9137bc430
Specify strict_max_version in Lightning manifest; r=philipp
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 6.6
Comment on attachment 9021691 [details] [diff] [review]
1503727-lightning-max-version-1.diff

Should've asked for this at the time, sorry.
Attachment #9021691 - Flags: approval-calendar-beta?(philipp)
Attachment #9021691 - Flags: approval-calendar-beta?(philipp) → approval-calendar-beta+
Target Milestone: 6.6 → 6.7
Beta (TB 64 beta 2 / Cal 6.6):
https://hg.mozilla.org/releases/comm-beta/rev/d8eadcb6eb3207b5b03aa89e6adb3ea2a447b8f3
Target Milestone: 6.7 → 6.6
You need to log in before you can comment on or make changes to this bug.