Closed Bug 1503813 Opened Last year Closed 9 months ago

Labels on map on https://transportnsw.info/trip#/ blacked

Categories

(Core :: Canvas: WebGL, defect, P1)

65 Branch
x86_64
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- wontfix
firefox65 --- verified
firefox66 --- verified

People

(Reporter: alberts, Assigned: jgilbert)

References

()

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

Visiting https://transportnsw.info/trip#/ today, the labels on the map are all scrambled and blacked out.

Here is a screenshot: https://screenshots.firefox.com/v0Lp5N4q7GM74khe/transportnsw.info

I checked an OSM https://www.openstreetmap.org/#map=14/-33.9218/151.2361 and a MapBox map https://www.mapbox.com/cartogram/, but they both rendered fine.
mozregression --good 2018-10-01 --bad 2018-10-31 --pref gfx.webrender.all:true -a https://transportnsw.info/trip#/
> 9:13.07 INFO: Last good revision: daf3e491e6fff54278e1564b7b7c25f115076e1c
> 9:13.07 INFO: First bad revision: 59befcc4a2d6886d0d642710dd4b0ebc25a62082
> 9:13.07 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=daf3e491e6fff54278e1564b7b7c25f115076e1c&tochange=59befcc4a2d6886d0d642710dd4b0ebc25a62082

> 59befcc4a2d6	Jeff Gilbert — Bug 1498070 - Simplify and cache framebuffer and texture completeness. - r=kvark

Also happens without WebRender, on MacOS.
Blocks: 1498070
Component: Graphics: WebRender → Canvas: WebGL
Flags: needinfo?(jgilbert)
Priority: -- → P3
Assignee: nobody → jgilbert
Flags: needinfo?(jgilbert)
Priority: P3 → P1
Status on this bug?
Flags: needinfo?(jgilbert)
It's fighting with other P1s. I'll see if I can timeslice it.
Flags: needinfo?(jgilbert)
See Also: → 1510175
Duplicate of this bug: 1519741

MozReview-Commit-ID: Ek1UIJjwQFH

Got it.

In RefreshSwizzle, we're updating the glTexParameter, but that is indirected through glActiveTexture.
So, if we have two textures in our draw call, texture X with format RGBA8 and texture Y with format A8, and glActiveTexture is left at TEXTURE0, we might try to set the swizzle for Y to [0,0,0,R], but will accidentally be applying this to X!

Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cd5c4d799e58
RefreshSwizzle must rebind its texture. r=lsalzman

Comment on attachment 9037705 [details]
Bug 1503813 - RefreshSwizzle must rebind its texture.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1498070

User impact if declined: Some apps (particularly users of MapBox) will display improperly when using WebGL.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Navigate to https://transportnsw.info/trip#/ on MacOS.
Labels should display properly, not as shown in this screenshot: https://screenshots.firefox.com/v0Lp5N4q7GM74khe/transportnsw.info

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Low risk because this is a very localized fix.

String changes made/needed: none

Attachment #9037705 - Flags: approval-mozilla-beta?
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Flags: qe-verify+

Thank you :)

Comment on attachment 9037705 [details]
Bug 1503813 - RefreshSwizzle must rebind its texture.

[Triage Comment]
Fixes issues with maps having black labels which have been reported a few times now over the past few releases. Approved for 65.0 RC2.

Attachment #9037705 - Flags: approval-mozilla-beta? → approval-mozilla-release+

I verified this issue on Mac OS on Nightly 66.0a1 (2019-01-24) and Firefox 65.0.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.