Windows hangs completely when clicking the URL above.

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Thomas Berg, Assigned: Matti)

Tracking

({hang})

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When clicking on the URL above (through Slashdot), Windows hangs completely. I
have to hardreset the machine.
If I block (using AtGuard) a javascript from a224.g.akamai.net it works OK (no
hang).
(Reporter)

Comment 1

16 years ago
Mozilla 1.0, buildid: 2002053012.

Comment 2

16 years ago
wfm using build 2002060704 on Win2k (trunk).
Keywords: hang

Comment 3

16 years ago
User-Agent: Mozilla/5.0 (Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
Build: 2002053012
JRE: version 1.4.0-rc

WFM, reporter, could you please confirm with JRE 1.4?

Comment 4

16 years ago
I don't see a Java applet on the page.

wfm with linux build 20020608 and 1.0 release

Thomas: if no one else can reproduce this, you might need to construct a
testcase that hangs for you. (save the page locally and whittle it down)

Comment 5

16 years ago
WFM with build 2002052306 under Windows ME.
(Reporter)

Comment 6

16 years ago
Created attachment 87064 [details]
Stripped down hang html (if eDexter is used).
(Reporter)

Comment 7

16 years ago
I think I found the problem.  It's not Mozilla (not alone at least).
I'm using eDexter (an ad blocker) which in this case blocks akamai-sites (which 
redirects to some lycos-hosted scripts).  (eDexter redirects the requests to 
127.0.0.1.)
It seems that the combination of blocking these akamai-sites and permitting the 
script generate the hang.  If I don't permit the script OR don't block the site 
a284.g.akamai.net i get no hang.  I have now removed involved akamai-sites from 
the blocking list (and the script doesn't seems to be activated - no question 
from AtGuard now !?).

(The hang is generated also with Java 1.4.1.01 and with IE 5.0 and Netscape 
4.77.  I attach a stripped down - but still "hangable" html - if You have 
eDexter and are curious...
The script that do the hang: 
http://a284.g.akamai.net/f/284/987/12h/hb.lycos.com/html_js/headerLayer.js )

Updated

16 years ago
Assignee: rogerl → Matti
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → imajes-qa

Comment 8

16 years ago
From the above description, it doesn't look like this is a bug in
JavaScript Engine that's causing this.Reassigning to Browser-General

Comment 9

16 years ago
In fact, from the reporter's comment above:

> The hang is generated also with Java 1.4.1.01 and with IE 5.0
  and Netscape 4.77.

Thomas, thank you for your careful testing of this! Based on your
findings, I'm going to resolve this as WORKSFORME. As you suggest,
it sounds like a problem with the eDexter software itself.

I'm also adding a notation to bug 147021 referencing this bug -
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.