Closed Bug 1504194 Opened 4 years ago Closed 4 years ago

Some videos never load because they have their content blocked blocked by Tracking Protection

Categories

(Firefox :: Protections UI, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 - disabled
firefox65 + verified

People

(Reporter: oana.botisan, Assigned: ehsan.akhgari)

References

(Blocks 2 open bugs)

Details

(Keywords: regression)

Attachments

(3 files)

[Affected versions]:
- Fx64.0b6
- Fx65.0a1

[Affected platforms]:
- macOS 10.13
- Ubuntu 16.04 x64
- Windows 10 x32
- Windows 7 x64

[Steps to reproduce]:
1. Launch Firefox.
2. Go to https://drive.google.com/file/d/0BwxFVkl63-lEY3l3ODJReDg3RzQ/view
3. Play the video if it doesn't automatically starts.

[Expected result]:
- The video starts to play.

[Actual result]:
- The video doesn't load. It remains in the state of loading even if the page is refresh. 

[Regression range]:
- This is a regression because it doesn't reproduce on Firefox 63.0.1.
- I will try to find a pushlog as soon as possible.

[Additional notes]:
- The Browser console has a lot of these types of errors shown:

 Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9xjqwio03_vxYxM7ZEm_CHP5Bv786OF” was blocked because it came from a tracker and content blocking is enabled.

 Error: This error message will be blank when privacy.resistFingerprinting = true. If it is really necessary, please add it to the whitelist in MediaError::GetMessage: 403: Forbidden

- While the video is being loaded:

Error: Untrusted URL: https://youtube.googleapis.com/videoplayback?id=990983c361291377&itag=59&source=webdrive&requiressl=yes&mm=30&mn=sn-c0q7lnsl&ms=nxu&mv=u&pl=23&sc=yes&ttl=transient&ei=gkfcW6Q71bapBd6oqegO&susc=dr&driveid=0BwxFVkl63-lEY3l3ODJReDg3RzQ&app=texmex&mime=video/mp4&dur=18.599&lmt=1454532954093869&mt=1541162050&ip=86.127.174.35&ipbits=0&expire=1541177282&cp=QVNJU0JfVlJWQ1hOOkllVzR0RndmR1hY&sparams=ip,ipbits,expire,id,itag,source,requiressl,mm,mn,ms,mv,pl,sc,ttl,ei,susc,driveid,app,mime,dur,lmt,cp&signature=2A735CC2EA9D674EE7741173F04E4C4B1521EF3089D90B273699B65C8A6EB986.9822C28E38AD2E3FF74ECF98582EB87B4E6F8CDF3E9B0F5E63D27C38AFCAC83C&key=us0&cpn=lnQuB4L1paXu40L3&c=WEB_EMBEDDED_PLAYER&cver=20181101
Regression:
Last good revision: 7508d586f2c875555b6f79ad8d92057a53013229
First bad revision: 3f5f46ca8ca0df1c34a9077fd4b479e291997a3f

Pushlog:https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=7508d586f2c875555b6f79ad8d92057a53013229&tochange=3f5f46ca8ca0df1c34a9077fd4b479e291997a3f
Ehsan, can you please take a look at this?
Flags: needinfo?(ehsan)
Blocks: etp-breakage
I see the following in web console:

Request to access cookie or storage on “https://apis.google.com/js/googleapis.proxy.js?onload=startup” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ” was blocked because it came from a tracker and content blocking is enabled. view
HTTP load failed with status 403. Load of media resource https://r4---sn-tt1e7n7r.c.drive.google.com/videoplayback?id=990983c361291377&itag=18&source=webdrive&requiressl=yes&mm=30&mn=sn-tt1e7n7r&ms=nxu&mv=u&pl=23&sc=yes&ttl=transient&ei=r8jcW7L3McSLuwKmj7vYCA&susc=dr&driveid=0BwxFVkl63-lEY3l3ODJReDg3RzQ&app=texmex&mime=video/mp4&dur=18.599&lmt=1454532797494487&mt=1541195067&ip=67.213.81.175&ipbits=0&expire=1541210351&cp=QVNJU0NfT1NTQlhOOkpxc1UySUNMUk56&sparams=ip,ipbits,expire,id,itag,source,requiressl,mm,mn,ms,mv,pl,sc,ttl,ei,susc,driveid,app,mime,dur,lmt,cp&signature=E20AB636032A7B3957E18FDEC568BE962BB8C2DF5A382292723393B449A5BE03.C818FF3317AD6BE728D3EA2AFFB6703BD0FFDDCFAC01174B73F9A263DB5B6646&key=us0&cpn=SfmmaOjzodtDW_BZ&c=WEB_EMBEDDED_PLAYER&cver=20181101 failed. embed
Error: This error message will be blank when privacy.resistFingerprinting = true.  If it is really necessary, please add it to the whitelist in MediaError::GetMessage: 403: Forbidden base.js:6732:19
Request to access cookie or storage on “https://drive.google.com/timedtext?authuser=0&id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&vid=990983c361291377&hl=en-US&type=list&tlangs=1&v=0BwxFVkl63-lEY3l3ODJReDg3RzQ&fmts=1&vssids=1” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk0r9bK0YyPFzbf6pc-hks2o6g3e8r” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk0r9bK0YyPFzbf6pc-hks2o6g3e8r” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk0ysmPe9IEMJFAgI0TVYiK2T4_n1L” was blocked because it came from a tracker and content blocking is enabled.
view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk0ysmPe9IEMJFAgI0TVYiK2T4_n1L” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk0ysmPe9IEMJFAgI0TVYiK2T4_n1L” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk0ysmPe9IEMJFAgI0TVYiK2T4_n1L” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk0ysmPe9IEMJFAgI0TVYiK2T4_n1L” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1J5wcP7fcokra6Cib4qYbXWlm5Zs” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1J5wcP7fcokra6Cib4qYbXWlm5Zs” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1QrXydrE8cXDrZUXto96WtM9PHOI” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1QrXydrE8cXDrZUXto96WtM9PHOI” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1QrXydrE8cXDrZUXto96WtM9PHOI” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1QrXydrE8cXDrZUXto96WtM9PHOI” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1pZCpaIc27CxG7P21jyz8t_cjbBa” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1pZCpaIc27CxG7P21jyz8t_cjbBa” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1pZCpaIc27CxG7P21jyz8t_cjbBa” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1pZCpaIc27CxG7P21jyz8t_cjbBa” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1pZCpaIc27CxG7P21jyz8t_cjbBa” was blocked because it came from a tracker and content blocking is enabled. view
Request to access cookie or storage on “https://docs.google.com/vt?id=0BwxFVkl63-lEY3l3ODJReDg3RzQ&s=AMedNnoAAAAAW9zk1pZCpaIc27CxG7P21jyz8t_cjbBa” was blocked because it came from a tracker and content blocking is enabled. view

Looking at the antitracking log, I saw messages such as:

Testing permission type 3rdPartyStorage^https://video.google.com for https://drive.google.com/...
Testing permission type 3rdPartyStorage^https://drive.google.com for https://drive.google.com/...

This isn't really consistent with our tracking protection rules, since these entities fall under the same eTLD+1.  I have a fix for this.
Flags: needinfo?(ehsan)
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
[Tracking Requested - why for this release]:
I don't think this needs to be tracked for 64, since the strict list used for the Enhanced Tracking Protection feature will be turned off automatically for late betas, see bug 1501657.
Makes sense, thanks. Given that 64.0b7 shipping tomorrow is the last with the early beta flag set, moving the status for 64 to disabled as well.
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c5fd8b5bef1e
Part 1: Make GetParentPrincipalAndTrackingOrigin() return the tracking URI r=baku
https://hg.mozilla.org/integration/autoland/rev/7b192230d7dd
Part 2: Grant access to trackers across the same eTLD+1 r=baku
https://hg.mozilla.org/integration/autoland/rev/b42a2be64f71
Part 3: Add tests for granting access to trackers across the same eTLD+1 r=baku
This behaviour change needs to be documented on MDN.  Steven, can you please help with that?  Thanks!
Flags: needinfo?(senglehardt)
Keywords: dev-doc-needed
Verified - Fixed on latest Nightly 65.0a1 (2018-11-28) (64-bit) on Windows 7/10 x64, Ubuntu 18.04. and Mac OS 10.14.
Status: RESOLVED → VERIFIED
Depends on: 1515165
You need to log in before you can comment on or make changes to this bug.