Closed Bug 1504234 Opened Last year Closed Last year

Update pdf.js to version 2.1.26

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 65
Tracking Status
firefox65 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

+++ This bug was initially created as a clone of Bug #1502855 +++

Changes since last update:
#10196 [Regression] Ensure that "Highlight All" is propagated to all pages for 'findagain' events where the findbar was previously closed (PR 10100 follow-up)
#10190 Add a helper method for `_getVisiblePages`, in `BaseViewer`, for the case where only a single page is displayed in the viewer
#10201 Reduce the number of redundant `updatetextlayermatches` events dispatched when calculating matches in `PDFFindController`
#10203 Change `canvasInRendering` to a `WeakSet` instead of a `WeakMap`
#10096 Remove the `attachDOMEventsToEventBus` functionality, since `EventBus` instances are able to re-dispatch events to the DOM (PR 10019, bug 1492849 follow-up)
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ed0afc9ed2a3
Update pdf.js to version 2.1.26. r=bdahl
https://hg.mozilla.org/mozilla-central/rev/ed0afc9ed2a3
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Blocks: 1506224
You need to log in before you can comment on or make changes to this bug.