Viewing CSS Style Rules on a quote <Q> crashes mozilla

VERIFIED DUPLICATE of bug 141022

Status

Other Applications
DOM Inspector
--
critical
VERIFIED DUPLICATE of bug 141022
16 years ago
11 years ago

People

(Reporter: Esben Mose Hansen, Assigned: Joe Hewitt (gone))

Tracking

({crash, testcase})

Trunk
x86
Linux
crash, testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020609
BuildID:    2002-05-30 aka mozilla 1.0

Not much else to add. It happens in trunk builds and 1.0. I havn't tried Windows
yet, but I will next time I boot windows.

BTW: It seems to me that its in the JS component that mozilla crashes(!). I
didn't think that was possible.

Reproducible: Always
Steps to Reproduce:
1.Open the DOM inspector
2.View attached testcase, or apparantly any page with a <Q> tag
3.Expand the document tree and select the Q node
4.On the upper right window, select "CSS Style Rules."

Actual Results:  crash

Expected Results:  The style rules, and especially no crash :O)

First 20 lines of a stack trace. 

#0  0x40b94199 in nsInspectorCSSUtils::IsRuleNodeRoot () from
/home/esben/omozilla/mozilla/dist/bin/components/libgkcontent.so
#1  0x415bad5c in inDOMUtils::GetStyleRules () from
/home/esben/omozilla/mozilla/dist/bin/components/libinspector.so
#2  0x401b37cc in XPTC_InvokeByIndex () from ./libxpcom.so
#3  0x407e9a97 in XPCWrappedNative::CallMethod () from
/home/esben/omozilla/mozilla/dist/bin/components/libxpconnect.so
#4  0x407eef8a in XPC_WN_CallMethod () from
/home/esben/omozilla/mozilla/dist/bin/components/libxpconnect.so
#5  0x400a3877 in js_Invoke () from ./libmozjs.so
#6  0x400ab18b in js_Interpret () from ./libmozjs.so
#7  0x400a38c6 in js_Invoke () from ./libmozjs.so
#8  0x400a8dec in js_Interpret () from ./libmozjs.so
#9  0x400a38c6 in js_Invoke () from ./libmozjs.so
#10 0x400a3ae8 in js_InternalInvoke () from ./libmozjs.so
#11 0x400b675d in js_SetProperty () from ./libmozjs.so
#12 0x400aa377 in js_Interpret () from ./libmozjs.so
#13 0x400a38c6 in js_Invoke () from ./libmozjs.so
#14 0x407e4c37 in nsXPCWrappedJSClass::CallMethod () from
/home/esben/omozilla/mozilla/dist/bin/components/libxpconnect.so
#15 0x407e131f in nsXPCWrappedJS::CallMethod () from
/home/esben/omozilla/mozilla/dist/bin/components/libxpconnect.so
#16 0x401b39b5 in PrepareAndDispatch () from ./libxpcom.so
#17 0x401b3a25 in nsXPTCStubBase::Stub3 () from ./libxpcom.so
#18 0x40a997e0 in nsEventListenerManager::HandleEventSubType () from
/home/esben/omozilla/mozilla/dist/bin/components/libgkcontent.so
#19 0x40a9b741 in nsEventListenerManager::HandleEvent () from
/home/esben/omozilla/mozilla/dist/bin/components/libgkcontent.so
#20 0x409f5ae3 in GlobalWindowImpl::HandleDOMEvent () from
/home/esben/omozilla/mozilla/dist/bin/components/libjsdom.so
(Reporter)

Comment 1

16 years ago
Created attachment 87026 [details]
A very simple testcase, added for your convenience :-)
(Reporter)

Comment 2

16 years ago
Adding appropriate keywords. 

I'll go test the Classic theme; if I don't write other comments the crash also
occurs for the classic theme.
Keywords: crash, testcase

Comment 3

16 years ago
sounds the same as bug 141022 'DOM Inspector crash if "CSS Style rules" is
selected on element matching no rules' and has the same stacktrace.

marking dupe.  reopen if you disagree

*** This bug has been marked as a duplicate of 141022 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
Guess you're right. Don't know why I didn't think so when I filed it. It even
has a patch, so I guess I'm in lock :-) Might as well VERIFY it.
Status: RESOLVED → VERIFIED
Product: Core → Other Applications
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.