Customize Mode's lazy browser is prematurely inserted

RESOLVED FIXED in Firefox 68

Status

()

defect
P3
normal
RESOLVED FIXED
8 months ago
3 months ago

People

(Reporter: Oriol, Assigned: Oriol)

Tracking

(Blocks 1 bug, Regression, {regression})

unspecified
Firefox 68
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr60 wontfix, firefox63 wontfix, firefox64 wontfix, firefox65 wontfix, firefox66 wontfix, firefox67 wontfix, firefox68 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

8 months ago
1. Open Customize Mode
2. Switch to another tab
3. Restart Firefox
4. Restore session

The browser console says:

  [bug 1345098] Lazy browser prematurely inserted via 'stop' property access:
  getter@chrome://browser/content/tabbrowser.js:2028:37
  setTab@resource:///modules/CustomizeMode.jsm:188:5
  restoreTab@resource:///modules/sessionstore/SessionStore.jsm:3987:7
  restoreTabs@resource:///modules/sessionstore/SessionStore.jsm:3811:9
  ssi_restoreWindow@resource:///modules/sessionstore/SessionStore.jsm:3599:7
  _restoreWindowsFeaturesAndTabs@resource:///modules/sessionstore/SessionStore.jsm:3679:7
  _restoreWindowsInReversedZOrder@resource:///modules/sessionstore/SessionStore.jsm:3696:5
  ssi_restoreWindows/<@resource:///modules/sessionstore/SessionStore.jsm:3751:7

https://searchfox.org/mozilla-central/rev/efc0d9172cb6a5849c6c4fc0f19d7fd5a2da9643/browser/components/customizableui/CustomizeMode.jsm#188
https://searchfox.org/mozilla-central/rev/efc0d9172cb6a5849c6c4fc0f19d7fd5a2da9643/browser/components/sessionstore/SessionStore.jsm#3987

This didn't happen until 2017-05-17 (6e3ca5b38f7173b214b10de49e58cb01890bf39d) because the Customize Mode tab was simply removed.
I can't test between 2017-05-18 (baf05f61bc14fdf45511bc1165ce76daa08c5c0f) and 2017-05-22 (9851fcb0bf4d855c36729d7de19f0fa5c9f69776) because of bug 1365933.
I can reproduce this bug since 2017-05-23 (5bc1c758ab57c1885dceab4e7837e58af27b998c)

Probably it's bug 1364483.
Getting to be too late for 64, but we could still take a patch for 65.
Happy to take a patch in nightly; if it seems low risk enough please feel free to request uplift to 65 beta.
Priority: -- → P3
Assignee

Comment 3

4 months ago

Alternative steps:

var tab = gBrowser.addTab('about:blank', {
  createLazyBrowser: true,
  triggeringPrincipal: Services.scriptSecurityManager.getSystemPrincipal(),
  allowInheritPrincipal: true,
});
console.log("Lazy tab:", !tab.linkedPanel);
gCustomizeMode.setTab(tab);
console.log("Lazy tab:", !tab.linkedPanel);
Assignee: nobody → oriol-bugzilla
Status: NEW → ASSIGNED
Assignee

Updated

3 months ago
Depends on: 1540530
Assignee

Updated

3 months ago
Keywords: checkin-needed

Comment 5

3 months ago

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c487b484577
Don't prematurely insert lazy tabs in customize mode. r=dao

Keywords: checkin-needed

Comment 6

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
No longer blocks: 1364483
Flags: in-testsuite+
Regressed by: 1364483
You need to log in before you can comment on or make changes to this bug.