The re-sizable "Street Address" field severely affects the Add/Edit form's layout

VERIFIED FIXED in Firefox 65

Status

()

P1
minor
VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: timea.babos, Assigned: dpino)

Tracking

Trunk
Firefox 65
Points:
---

Firefox Tracking Flags

(firefox63 disabled, firefox64 disabled, firefox65 disabled)

Details

(Whiteboard: [webpayments-reserve])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 months ago
Posted video Video of the issue
[Affected versions]: 
Nightly 65.0a1 

[Affected platforms]:
Platforms: Windows 10 x 64, Windows 7 x32, Mac OS X 10.13 and on Ubuntu 16.04 x64.

[Preconditions]:
1. Set the pref dom.payments.request.enabled to "true"
2. Set browser.search.region to "US" or "CA" if you are outside of the US or Canada
3. Make sure you have at least one Shipping Address and one Credit Card saved in your browser

[Steps to reproduce]:
1. Go to "https://rsolomakhin.github.io/pr/single/" page and click on "Buy".
2. Select "Add" for a new shipping address
3. Resize the "Street Address* field by dragging the right bottom corner of the field

[Expected result]:
The field should be resized within reasonable limits without messing up the form's layout.

[Actual result]:
The "Street Address" field can be resized in a manner that severely affects the Address Form layout. Please check the attached video. The created layout is also saved within the payment session for all Add/Edit forms.
Flags: qe-verify+
For one, we should allow it to only be resized vertically which is a trivial CSS fix.
Severity: normal → minor
status-firefox63: unaffected → disabled
status-firefox64: unaffected → disabled
status-firefox65: affected → disabled
Priority: -- → P3
Whiteboard: [webpayments] [triage] → [webpayments-reserve]
(Assignee)

Comment 2

4 months ago
Vertical resize only in addressForm street-address.
Attachment #9024686 - Flags: review?(MattN+bmo)
Assignee: nobody → dpino
Status: NEW → ASSIGNED
Priority: P3 → P1
Comment on attachment 9024686 [details] [diff] [review]
Bug-1504675-Allow-vertical-resize-only-in-WebPayment.patch

Review of attachment 9024686 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks

::: browser/components/payments/res/containers/address-form.css
@@ +55,5 @@
>  }
> +
> +#street-address {
> +  resize: vertical;
> +}

This is good but can you put it in https://searchfox.org/mozilla-central/rev/7f7c353e969e61a6a85201cc8ad3c3de12ac30d8/browser/extensions/formautofill/skin/shared/editAddress.css#109 so it's shared with the dialog in preferences (even though that doesn't seem to be affected) since this change is more about editAddress than about address-form.
Attachment #9024686 - Flags: review?(MattN+bmo) → feedback+
(Assignee)

Comment 4

4 months ago
Moved CSS formatting style rule to editAddress.css
Attachment #9024686 - Attachment is obsolete: true
Attachment #9024946 - Flags: review?(MattN+bmo)
Comment on attachment 9024946 [details] [diff] [review]
Bug-1504675-Allow-vertical-resize-only-in-WebPayment.patch

Review of attachment 9024946 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #9024946 - Flags: review?(MattN+bmo) → review+
Keywords: checkin-needed

Comment 6

4 months ago
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/07332eea2976
Allow vertical resize only in WebPayments's address-form street-address field r=MattN
Keywords: checkin-needed

Comment 7

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/07332eea2976
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65

Comment 8

4 months ago
Verified as fixed on Firefox Nightly 65.0a1 (2018-11-14) on Windows 10 x 64, Windows 7 x32, Mac OS X 10.13 and on Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.