It's still possible to close the wrong tab in about:performance

VERIFIED FIXED in Firefox 64

Status

()

VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: florian, Assigned: florian)

Tracking

Trunk
mozilla65
Points:
---

Firefox Tracking Flags

(firefox64 verified, firefox65 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 months ago
My patch in bug 1502080 freezes the sort order for 5s whenever the user moves the mouse.

One case I encountered is that due to the sort order becoming stable, I was comfortable clicking the close icon several times in a row to close a set of similar "low energy impact" tabs. After 5s the order changed right when I was clicking, and I closed a tab I didn't expect to close.

I think this can easily be fixed by updating the _lastMouseEvent timestamp on click events in addition to mousemove events. I think we need this at least for clicks on the action icons and on the twisty icons. I'm less sure about clicks that change the selection, but I guess it won't hurt.
(Assignee)

Comment 1

5 months ago
Posted patch PatchSplinter Review
Attachment #9022611 - Flags: review?(felipc)
Attachment #9022611 - Flags: review?(felipc) → review+

Comment 2

5 months ago
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/caee2a504928
Freeze the sort order of about:performance for 5s on click events, r=felipe.

Comment 3

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/caee2a504928
Status: NEW → RESOLVED
Last Resolved: 5 months ago
status-firefox65: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
(Assignee)

Comment 4

5 months ago
Comment on attachment 9022611 [details] [diff] [review]
Patch

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1502080

User impact if declined: Clicking the close button several times in a row may result in closing the wrong tab after closing the expected tab during the first 5s.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Needs manual test only because there's no automated test. The patch is trivially simple.

List of other uplifts needed: Bug 1502080

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Trivial follow-up to bug 1502080.

String changes made/needed: none
Attachment #9022611 - Flags: approval-mozilla-beta?
Comment on attachment 9022611 [details] [diff] [review]
Patch

about:performance followup for bug 1502080, approved for 64.0b8
Attachment #9022611 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 6

5 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/7d121c076bc7
status-firefox64: --- → fixed

Comment 7

4 months ago
Verified on Nightly 65(20181112100105) and Beta 64b8(20181108141956), that sort order is frozen for 5s after mouse click events.
Status: RESOLVED → VERIFIED
status-firefox64: fixed → verified
status-firefox65: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.