Closed Bug 1504840 Opened Last year Closed 6 months ago

Blue "unseen" indicator on folders makes the folder name unreadable in Mojave Dark Mode

Categories

(Thunderbird :: Theme, defect)

Unspecified
macOS
defect
Not set

Tracking

(thunderbird64 fixed, thunderbird65 fixed)

RESOLVED FIXED
Thunderbird 65.0
Tracking Status
thunderbird64 --- fixed
thunderbird65 --- fixed

People

(Reporter: justdave, Assigned: Paenglab)

Details

Attachments

(2 files)

With the Mojave OS set to Dark Mode, the blue "unseen" folder names are unreadable in the folder list, because the dark blue blends in with the dark background.  I suggest when in Dark Mode the folder names should be a brighter blue color to provide a little more contrast (just like the other folder names become white instead of black when in dark mode).  The blue when not in Dark Mode is fine how it is.
Based on the tab tree line blue but made lighter to be better visible.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9023053 - Flags: review?(jorgk)
Attachment #9023053 - Flags: approval-comm-esr60?
Attachment #9023053 - Flags: approval-comm-beta?
Attached image newMail.png
Hoe it looks with the patch.
indeed, much better. :)
Comment on attachment 9023053 [details] [diff] [review]
1504840-newMail-blue.patch

OK. Not easy to find a "blue" folder to start with.

Why do you need uplift to ESR 60? As far as I can see, the folder tree in the dark theme isn't dark.
Attachment #9023053 - Flags: review?(jorgk)
Attachment #9023053 - Flags: review+
Attachment #9023053 - Flags: approval-comm-beta?
Attachment #9023053 - Flags: approval-comm-beta+
Comment on attachment 9023053 [details] [diff] [review]
1504840-newMail-blue.patch

Ah yes. I was used to set ESR too. :-(
Attachment #9023053 - Flags: approval-comm-esr60?
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/c7f02af5ea18
Use a light blue "New mail indication" with dark theme. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 65.0

This got regressed... it's broken again in 68.0b1 Build ID 20190613171710

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Please don't reopen a fixed bug. Create a new for a regression.

More information would be helpful. Do you use the default TB theme with dark OS theme? If yes, could you try to enable the dark TB theme? When this fixes the issue, it's bug 1540515 that regresses.

Status: REOPENED → RESOLVED
Closed: Last year6 months ago
Resolution: --- → FIXED

Yeah, explicitly setting the dark theme does resolve it. Will go add myself to bug 1540515 then. Thanks!

You need to log in before you can comment on or make changes to this bug.