Closed Bug 1504843 Opened Last year Closed Last year

push.services.mozilla.com access causes Firefox Desktop raptor to crash with FATAL ERROR: Non-local network connections are disabled

Categories

(Testing :: Raptor, defect)

defect
Not set

Tracking

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 fixed, firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: bc, Assigned: bc)

References

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1501040 disabled non-local access in order to run an unsigned webext in beta. As a result when running raptor speedometer and other tests locally on Firefox the test terminates due to 

FATAL ERROR: Non-local network connections are disabled and a connection attempt to push.services.mozilla.com (34.223.240.82) was made.

We can fix this by adding the 

user_pref("dom.push.connection.enabled", false);

pref to the raptor user.js preferences file.
This works for me locally though I don't know if there are other prefs we should be setting that might bite us in the future.
Attachment #9022750 - Flags: review?(rwood)
See Also: → 1504845
Thanks :bc for tracking this down! More info for the bug, MOZ_DISSABLE_NONLOCAL_CONNECTIONS is set on beta and then turned off again after startup, but only turned off for pageload-type tests (tp6, gdocs) [1] since benchmark tests are accessed locally via localhost. Except for as you found out, when Firefox is trying to contact push.services.mozilla.com.

The other option is to set MOZ_DISABLE_NONLOCAL_CONNECTIONS back to 0 (after startup) for benchmark type tests also. However maybe we should be setting this pref anyway - as you pointed out the same pref is already being set in /testing/profiles/unittest/user.js (which raptor doesn't use).

[1] https://searchfox.org/mozilla-central/rev/7c848ac7630df5baf1314b0c03e015683599efb9/testing/raptor/raptor/raptor.py#252
Correction - it's set everywhere, but we had to set it * for * running raptor on beta, since raptor is an unsigned web ext.
What I don't understand is why this is not showing up in production.
Comment on attachment 9022750 [details] [diff] [review]
disable-push-services.patch

Review of attachment 9022750 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #9022750 - Flags: review?(rwood) → review+
Pushed by bclary@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7301222ceaea
[raptor] Disable access to push.services.mozilla.com to prevent non-local network access, r=rwood.
https://hg.mozilla.org/mozilla-central/rev/7301222ceaea
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Whiteboard: [checkin-needed-beta]
Blocks: 1483695
See Also: → 1554724
You need to log in before you can comment on or make changes to this bug.