Autofilled search shortcuts should show a single "Search with Engine" heuristic result in the popup

VERIFIED FIXED in Firefox 64

Status

()

defect
P1
normal
VERIFIED FIXED
7 months ago
6 months ago

People

(Reporter: adw, Assigned: adw)

Tracking

(Blocks 1 bug)

unspecified
Firefox 65
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox64 verified, firefox65 verified)

Details

Attachments

(2 attachments)

Assignee

Description

7 months ago
This is something Verdi and I noticed today.  If you type @g so that @google is autofilled, the popup shows results that match @g.  It should show only the single "Search with Google" heuristic result, the way it does if you actually typed out @google yourself.
Assignee

Comment 1

7 months ago
All we need to do is set `_searchEngineAliasMatch` with an empty query so that we don't try to add any more results. That hits the existing case where the user types out a full @ alias and we show only the "search with engine" heuristic result.

Comment 3

7 months ago
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/867aaeefa9ad
Autofilled search shortcuts should show a single "Search with Engine" heuristic result in the popup r=mak

Comment 4

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/867aaeefa9ad
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Assignee

Comment 5

7 months ago
STR for QA:

1. Type "@google @google" in the urlbar and press the return key.  Firefox should load a Google results page for "@google".
2. Type "@g" in the urlbar.  The text in the urlbar should be autofilled to "@google " and the urlbar popup should open.
3. Verify that the only result in the popup is "Search with Google".  There should *not* be a second result that shows the "@google" results page you just loaded.  (There may be a "Tip: Get help finding things" tooltip at the top of the popup, which is not a result, and that's OK)
Flags: qe-verify+
Flags: in-testsuite+
Assignee

Comment 7

6 months ago
Posted patch Beta/64 patchSplinter Review
[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Not a regression but improvement to search shortcuts in the awesomebar: see bug 1496772

User impact if declined: We've landed a group of other improvements to search shortcuts in 64 (see bug 1496772), and this bug will make a large improvement to that feature. Especially considering the low risk, the reward-to-risk ratio is high.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Please see comment 5

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Small patch, well understood, has automated tests. Also, a try push using mozilla-beta: https://treeherder.mozilla.org/#/jobs?repo=try&revision=63067f2ae02f5d2e6f91f60e08344d8d131101b3

String changes made/needed: None
Attachment #9024840 - Flags: approval-mozilla-beta?
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Hi,
I have just tested this in the latest Nightly 65 build (id: 20181113220101). The issue is Verified Fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Comment on attachment 9024840 [details] [diff] [review]
Beta/64 patch

search shortcuts improvement, verified in nightly; approved for 64.0b10
Attachment #9024840 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Hi,
I have just tested this in the latest Beta 64.0b11  (id: 20181119162153). Marking the firefox64 flag as verified.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.