Closed Bug 1505031 Opened 2 years ago Closed 2 years ago

JavaScript error: aboutPerformance.js, ReferenceError: event is not defined

Categories

(Toolkit :: Performance Monitoring, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox64 + fixed
firefox65 --- fixed

People

(Reporter: florian, Assigned: florian)

References

Details

Attachments

(1 file)

[Tracking Requested - why for this release]: this code works on Nightly but will fail on beta and release.

JavaScript error: chrome://global/content/aboutPerformance.js, line 1104: ReferenceError: event is not defined

And same error at line 1158.

This happens when dom.window.event.enabled is false, which is true for release builds since bug 1493869.
Attached patch PatchSplinter Review
Attachment #9022944 - Flags: review?(felipc)
Attachment #9022944 - Flags: review?(felipc) → review+
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1a62566c1baf
stop using the global 'event' object in about:performance, r=felipe.
https://hg.mozilla.org/mozilla-central/rev/1a62566c1baf
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Comment on attachment 9022944 [details] [diff] [review]
Patch

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: 1491384, 1496782

User impact if declined: Clicking or double clicking won't work (and will produce a JS error in the browser console) in about:performance on release builds.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: none

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Trivial fix

String changes made/needed: none
Attachment #9022944 - Flags: approval-mozilla-beta?
Comment on attachment 9022944 [details] [diff] [review]
Patch

trivial fix for new about:performance, approved for 64.0b8
Attachment #9022944 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
See Also: → 1504890
You need to log in before you can comment on or make changes to this bug.