:hover response is very slow

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Brant Gurganus, Assigned: dcone (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020608
BuildID:    2002060808

I use a :hover item in CSS to cause a border to go around my buttons when they
are hovered over.  The problem is that in Mozilla, the hover response is very
slow even on a 512MB AMD Athlon XP 1700+ system.  This even happens when I load
the local versions of the pages.  No JavaScript is involved.

Reproducible: Always
Steps to Reproduce:
1. Load the page at http://www.cherokeescouting.org/OtherUnits/Troop545IIN/.
2. Mouseover the menu.

Actual Results:  Response to :hover is very slow.

Expected Results:  Response should be almost instantaneous.

This started happening after adding the background graphics to the rest of the
page.  Maybe there is a bottle neck in the graphics or style system libraries. 
All graphics with the exception of the favorites icon is a PNG compressed with
pngcrush from SourceForge.  Switching to the tab containing this page is also
slow.  I think this is pointing to a graphics library issue, but I am not an expert.
-> GFX
Assignee: Matti → kmcclusk
Component: Browser-General → GFX Compositor
QA Contact: imajes-qa → petersen
(Reporter)

Comment 2

16 years ago
I changed the background for the page from PNG to JPG and that sped up the page
alot.  I will attach the files.
(Reporter)

Comment 3

16 years ago
Created attachment 87076 [details]
Old background

This is the old background for the page.  It is a PNG compressed with pngcrush.
(Reporter)

Comment 4

16 years ago
Created attachment 87077 [details]
New background

This is the new background.  It is the original PNG saved as a JPG at about 70%
quality.  I then used JPG cleaner to remove 33bytes of comment junk.  It looks
like the issue was related to the background type either the size of the
original or the fact that the original was PNG.
-> dcone
Assignee: kmcclusk → dcone
(Assignee)

Comment 6

16 years ago
There are fixes in for the PNG alpha code that should help this.  Also the
internal format of the image should not matter since we store our images in an
interal format so the image type should not matter except on load.  If the image
has alpha in it.. that will matter alot.  I ran the original with the latest
trunk and it works fine.  I am assuming my PNG fixes for alpha fixed this.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.