Closed Bug 1505290 Opened 3 years ago Closed 1 year ago

41.73% tsvgx (linux64-qr) regression on push 7a308f25794fefdd541d3c913fb807c6ee495615 (Tue Nov 6 2018)

Categories

(Core :: Graphics: WebRender, defect, P3)

Unspecified
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- disabled
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- disabled
firefox66 --- disabled
firefox69 --- wontfix

People

(Reporter: igoldan, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(5 keywords, Whiteboard: [qf:p3:responsiveness])

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=7a308f25794fefdd541d3c913fb807c6ee495615

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 42%  tsvgx linux64-qr opt e10s stylo     245.27 -> 347.63

Improvements:

 23%  tsvgr_opacity linux64-qr opt e10s stylo     155.84 -> 120.12
  7%  tsvg_static linux64-qr opt e10s stylo       68.62 -> 64.14


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=17389

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Performance_sheriffing/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Performance_sheriffing/Talos/RegressionBugsHandling
Component: General → Graphics: WebRender
Product: Testing → Core
I understand this Linux QR is not a priority. Still, if you file any bugs against this issue, do link them here also.
Flags: needinfo?(matt.woodrow)
We also detected these new Raptor regressions:

== Change summary for alert #17398 (as of Tue, 06 Nov 2018 19:46:18 GMT) ==

Regressions:

  9%  raptor-motionmark-animometer-firefox linux64-qr opt           42.55 -> 38.87
  2%  raptor-motionmark-animometer-firefox windows10-64-qr opt      39.84 -> 38.87

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=17398
A bit surprising that we regressed tsvgx by this much, especially since it improved on Windows.

I'm still looking into tsvgx regressions, so hopefully this gets better again.
Flags: needinfo?(matt.woodrow)
P4 until we understand the cause
Blocks: wr-linux
Priority: -- → P3
(In reply to Maire Reavy [:mreavy] Plz needinfo from comment #4)
> P4 until we understand the cause

The comment was meant for another bug
(In reply to Matt Woodrow (:mattwoodrow) from comment #3)
> A bit surprising that we regressed tsvgx by this much, especially since it
> improved on Windows.
> 
> I'm still looking into tsvgx regressions, so hopefully this gets better
> again.

If you filed a separate bug for this investigation, please link it against this one.
Flags: needinfo?(matt.woodrow)
Apologies, added the dependent bug now.
Depends on: 1416652
Flags: needinfo?(matt.woodrow)

Happy to take a patch in nightly or even in beta 66 for this.
I'm marking it fix-optional to remove it from weekly triage.

Whiteboard: [qf]
Whiteboard: [qf] → [qf:p3:responsiveness]

Looking at the graph for the last year, I think this got fixed, as we are back around the original value we regressed from (250s). You can see a jump around April 27th, 2019 that brought us back to baseline.

https://treeherder.mozilla.org/perf.html#/graphs?highlightAlerts=1&series=mozilla-central,1648455,1,1&timerange=31536000

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.