Port bug 1504725 to TB: Error when trying to restart into new language on Beta

RESOLVED FIXED in Thunderbird 65.0

Status

defect
RESOLVED FIXED
10 months ago
10 months ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

Thunderbird 65.0

Thunderbird Tracking Flags

(thunderbird64 fixed, thunderbird65 fixed)

Details

Attachments

(1 attachment)

From comment 0:
Nothing happens when clicking the "Apply and restart" button after switching browser languages on Beta.

There is an error in the console: ReferenceError: event is not defined

And comment 6:
Just got the mozregression working, tracked it down to bug 1493869. So having this work on Nightly but not Beta is expected but sounds like this bug could easily happen again.
Port of https://hg.mozilla.org/mozilla-central/rev/84367a375806
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9023188 - Flags: review?(jorgk)
Attachment #9023188 - Flags: approval-comm-beta?
Comment on attachment 9023188 [details] [diff] [review]
1505291-language-event.patch

You need to type - bug 1504725 comment #0 - and - bug 1504725 comment #6 - for this to work ;-)

Thanks for watching C-C activities!!
Attachment #9023188 - Flags: review?(jorgk)
Attachment #9023188 - Flags: review+
Attachment #9023188 - Flags: approval-comm-beta?
Attachment #9023188 - Flags: approval-comm-beta+
I know, but when I quote the whole comment I thought it's not needed to link completely.
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/29dbc84a0a79
Port bug 1504725 to TB: Explicitly pass event to language change handler. r=jorgk DONTBUILD
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
I've pushed this now since we may have a Daily/Nightly build again today. We'll see.
Target Milestone: --- → Thunderbird 65.0
Version: 60 → 64
You need to log in before you can comment on or make changes to this bug.