Closed Bug 1505372 Opened 6 years ago Closed 6 years ago

esr60 "./mach clang-format -p dom/presentati on" is failing on a missing job

Categories

(Developer Infrastructure :: Lint and Formatting, defect)

60 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1467605

People

(Reporter: Sylvestre, Assigned: andi)

References

Details

Attachments

(1 obsolete file)

Exception: Missing fetch job for toolchain-linux64-mingw32-gcc: binutils-2.27
Andi, could you please try to fix that? Thanks :)
Flags: needinfo?(bpostelnicu)
Assignee: nobody → bpostelnicu
Flags: needinfo?(bpostelnicu)
What happens here is very strange, we have bug 1460777 that fixes this issue in m-c but in ESR60 we have this push https://hg.mozilla.org/releases/mozilla-esr60/annotate/b87ec7457a97/taskcluster/taskgraph/transforms/job/__init__.py#l164
We should also need the logic in order to skip the artifacts that require 'fetches' when specifying the 'from_build' flag, that can be found here https://searchfox.org/mozilla-central/source/python/mozbuild/mozbuild/mach_commands.py#1433.
This looks like a potential regression from the recent uplift to esr60 that :tomprince landed.
Flags: needinfo?(mozilla)
Oh, maybe not. Looks like this was filed before that landed. Tom, I'll leave the needinfo just in case you have any insight into what happened here.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mozilla)
Resolution: --- → DUPLICATE
Attachment #9024468 - Attachment is obsolete: true
Product: Firefox Build System → Developer Infrastructure
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: