Tables displays incorrectly

VERIFIED FIXED in Firefox 63

Status

()

defect
VERIFIED FIXED
8 months ago
7 months ago

People

(Reporter: alex_mayorga, Assigned: emilio)

Tracking

({nightly-community, regression, site-compat})

63 Branch
mozilla65
x86
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63+ verified, firefox64+ verified, firefox65+ verified)

Details

()

Attachments

(1 attachment)

Reporter

Description

8 months ago
¡Hola!

The table at https://support.cloudflare.com/hc/en-us/articles/115001186052 displays incorrectly on Firefox, Beta, Developer Edition and Nightly.

The same table looks OK in Chrome.

¡Gracias!
Alex
Assignee

Comment 1

8 months ago
Ugh, thanks for the catch, looks like bug 1478455. should've been backed out, but wasn't in the end.
Assignee: nobody → emilio
Blocks: 1478455
Assignee

Comment 2

8 months ago
It breaks websites.
Assignee

Comment 4

8 months ago
Comment on attachment 9023425 [details]
Bug 1505520 - Back out bug 1478455.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1478455

User impact if declined: See comment 0

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: See comment 0.

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It reverts to behavior pre-bug 1478455, which is what we've shipped since forever. Bug 1478455 was only needed by work that was disabled by default in bug 1484587.

String changes made/needed: none
Attachment #9023425 - Flags: approval-mozilla-release?
Attachment #9023425 - Flags: approval-mozilla-beta?

Comment 5

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1d6dba09c494
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Comment on attachment 9023425 [details]
Bug 1505520 - Back out bug 1478455.

revert web-breaking change; approved for 64.0b8
Attachment #9023425 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
:pascalc fyi
Comment on attachment 9023425 [details]
Bug 1505520 - Back out bug 1478455.

Revert web-breaking change, on beta with no new reported regression, approved for 63.0.3, thanks.
Attachment #9023425 - Flags: approval-mozilla-release? → approval-mozilla-release+
I have reproduced this bug using the STR from comment 0, on an affected Nightly build 2018-11-07.

I cannot see the rendering issues anymore on latest Nightly 65.0a1, Beta 64.0b9 and dot Release 63.0.3. Tested across platforms: Win 10 x64, macOS 10.13 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.