Closed Bug 1505608 Opened 10 months ago Closed 10 months ago

`test-array.so: Couldn't find .bss. Skipping` in some corner case

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox-esr60 unaffected, firefox63 wontfix, firefox64 fixed, firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- wontfix
firefox64 --- fixed
firefox65 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

No description provided.
In bug 1470701, we added a dummy global variable so that it ends up in
the bss section, making it large enough for two pointers. Unfortunately,
in some cases, the symbol is eliminated by the linker because it is
unused. So we try to ensure it stays there.
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/bc2f290531d7
Try to ensure the bss section of the elfhack testcase stays large enough. r=froydnj
Comment on attachment 9023473 [details]
Bug 1505608 - Try to ensure the bss section of the elfhack testcase stays large enough.

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1470701

User impact if declined: Failure to build on Linux in some cases because of a test failure during the build

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): This only changes a testcase that is used during the build to ensure elfhack does its work correctly. The test failed because the testcase assumptions can be broken when it is linked.

String changes made/needed: N/A
Attachment #9023473 - Flags: approval-mozilla-esr60?
Attachment #9023473 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/bc2f290531d7
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Blocks: 1470701
Bug 1470701 isn't on esr60, did you want to also request uplift there?
Comment on attachment 9023473 [details]
Bug 1505608 - Try to ensure the bss section of the elfhack testcase stays large enough.

approved for 64.0b9
Attachment #9023473 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Julien Cristau [:jcristau] from comment #5)
> Bug 1470701 isn't on esr60, did you want to also request uplift there?

Oh, right, no need for uplift then. Debian ESR60 was affected because I applied bug 1470701 downstream (for e.g. armhf).
Attachment #9023473 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60-
You need to log in before you can comment on or make changes to this bug.