Build fails with gnu compiler and gnu utils(ld)...

RESOLVED DUPLICATE of bug 162873

Status

P2
major
RESOLVED DUPLICATE of bug 162873
16 years ago
16 years ago

People

(Reporter: t_mutreja, Assigned: mcs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: needs work)

(Reporter)

Description

16 years ago
In the latest builds, it seems that ldap expects Sun's ld to be used, even when
the gnu ld exists in the path. 

I checked out the latest code(June 10' 2002) from cvs-mirror.mozilla.org. On
Solaris 2.6, every time the build is failing with following error messages:

======= making ./libldap50.a
rm -f libldap50.a; /usr/local/bin/ar cr libldap50.a ./abandon.o ./add.o ./bind.o
./cache.o ./charray.o ./charset.o ./compare.o ./compat.o ./control.o
./countvalues.o ./delete.o ./disptmpl.o ./dsparse.o ./error.o ./extendop.o
./free.o ./freevalues.o ./friendly.o ./getattr.o ./getdn.o ./getdxbyname.o
./getentry.o ./getfilter.o ./getoption.o ./getvalues.o ./memcache.o ./message.o
./modify.o ./open.o ./os-ip.o ./proxyauthctrl.o ./psearch.o ./referral.o
./regex.o ./rename.o ./request.o ./reslist.o ./result.o ./saslbind.o ./sbind.o
./search.o ./setoption.o ./sort.o ./sortctrl.o ./srchpref.o ./tmplout.o ./ufn.o
./unbind.o ./unescape.o ./url.o ./utf8.o ./vlistctrl.o; ranlib libldap50.a
-L/home/tm/mdev/mozilla/dist/lib -llber50
ranlib: -L/home/tm/mdev/mozilla/dist/lib: No such file or directory
gmake-3.79[7]: *** [libldap50.a] Error 9
gmake-3.79[7]: Leaving directory
`/home/tm/mdev/mozilla/directory/c-sdk/ldap/libraries/libldap'
gmake-3.79[6]: *** [export] Error 2
gmake-3.79[6]: Leaving directory
`/home/tm/mdev/mozilla/directory/c-sdk/ldap/libraries'
gmake-3.79[5]: *** [export] Error 2
gmake-3.79[5]: Leaving directory `/home/tm/mdev/mozilla/directory/c-sdk/ldap'
gmake-3.79[4]: *** [export] Error 2
gmake-3.79[4]: Leaving directory `/home/tm/mdev/mozilla/directory/c-sdk'
gmake-3.79[3]: *** [ldap] Error 2
gmake-3.79[3]: Leaving directory `/home/tm/mdev/mozilla'
gmake-3.79[2]: *** [default] Error 2
gmake-3.79[2]: Leaving directory `/home/tm/mdev/mozilla'
gmake-3.79[1]: *** [build] Error 2
gmake-3.79[1]: Leaving directory `/home/tm/mdev/mozilla'
gmake-3.79: *** [build] Error 2


On modifying /mozilla/directory/c-sdk/lpad/libraries/libldap/Makefile at line
number 269 
to remove $(EXTRA_LIB) i.e. I changed 
         $(LINK_LIB) $(EXTRA_LIBS) 
to 
         $(LINK_LIB) 

I got stuck at the very next step with following errors: 


======= making ./libldap50.a
rm -f libldap50.a; /usr/local/bin/ar cr libldap50.a ./abandon.o ./add.o ./bind.o
./cache.o ./charray.o ./charset.o ./compare.o ./compat.o ./control.o
./countvalues.o ./delete.o ./disptmpl.o ./dsparse.o ./error.o ./extendop.o
./free.o ./freevalues.o ./friendly.o ./getattr.o ./getdn.o ./getdxbyname.o
./getentry.o ./getfilter.o ./getoption.o ./getvalues.o ./memcache.o ./message.o
./modify.o ./open.o ./os-ip.o ./proxyauthctrl.o ./psearch.o ./referral.o
./regex.o ./rename.o ./request.o ./reslist.o ./result.o ./saslbind.o ./sbind.o
./search.o ./setoption.o ./sort.o ./sortctrl.o ./srchpref.o ./tmplout.o ./ufn.o
./unbind.o ./unescape.o ./url.o ./utf8.o ./vlistctrl.o; ranlib libldap50.a
======= making ./libldap50.so
/usr/local/bin/ld -G -h libldap50.so -f libatomic.so    -o libldap50.so
./abandon.o ./add.o ./bind.o ./cache.o ./charray.o ./charset.o ./compare.o
./compat.o ./control.o ./countvalues.o ./delete.o ./disptmpl.o ./dsparse.o
./error.o ./extendop.o ./free.o ./freevalues.o ./friendly.o ./getattr.o
./getdn.o ./getdxbyname.o ./getentry.o ./getfilter.o ./getoption.o ./getvalues.o
./memcache.o ./message.o ./modify.o ./open.o ./os-ip.o ./proxyauthctrl.o
./psearch.o ./referral.o ./regex.o ./rename.o ./request.o ./reslist.o ./result.o
./saslbind.o ./sbind.o ./search.o ./setoption.o ./sort.o ./sortctrl.o
./srchpref.o ./tmplout.o ./ufn.o ./unbind.o ./unescape.o ./url.o ./utf8.o
./vlistctrl.o -Blocal -M./libldap.exp -L/home/tm/mdev/mozilla/dist/lib -llber50 
/usr/local/bin/ld: unrecognized option '-Blocal'
/usr/local/bin/ld: use the --help option for usage information
gmake-3.79[3]: *** [libldap50.so] Error 1
gmake-3.79[3]: Leaving directory
`/home/tm/mdev/mozilla/directory/c-sdk/ldap/libraries/libldap'
gmake-3.79[2]: *** [export] Error 2
gmake-3.79[2]: Leaving directory
`/home/tm/mdev/mozilla/directory/c-sdk/ldap/libraries'
gmake-3.79[1]: *** [export] Error 2
gmake-3.79[1]: Leaving directory `/home/tm/mdev/mozilla/directory/c-sdk/ldap'
gmake-3.79: *** [export] Error 2

Comment 1

16 years ago
.
Assignee: seawood → mcs
Component: Build Config → LDAP C SDK
Product: Browser → Directory
QA Contact: granrose → nobody
(Assignee)

Updated

16 years ago
Priority: -- → P2
Whiteboard: needs work

Comment 2

16 years ago
Marking as a duplicate of bug 162873, since there is a work around discussed
there:  run make from the mozilla/directory/c-sdk/ldap/libraries/libldap directory.

*** This bug has been marked as a duplicate of 162873 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Spam for bug 129472
QA Contact: nobody → nobody
You need to log in before you can comment on or make changes to this bug.