Closed Bug 1505687 Opened 3 years ago Closed 3 years ago

about:privatebrowsing text has unwanted top margin before lists

Categories

(Firefox :: Private Browsing, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox65 --- verified

People

(Reporter: fvsch, Assigned: fvsch)

Details

Attachments

(4 files)

The spacing before the two bullet lists in about:privatebrowsing is off.

The reason seems to be that the margins of the UL elements don't collapse with the paragraphs (overflow:auto on the parent), and the LI overflow the UL because they're floated.

This seems like a straightforward CSS fix. I'll probably submit a patch, since this has been bothering me for years. ^^
- Fix bullet list margins.
- Improve :hover:active style for links.
- Improve narrow width layout: flexible list item width, more reasonable line-heights, move content blocking icon inline.
Before/after result, with a narrow window. (Result of the patch on the right.)
Before/after result, with a 1280px-wide window. (Result of the patch on the right.)

This screenshot also shows the :hover:active state for the "See how it works" button. We currently inherit a style that makes the text blue, which is not great on a Photon Purple background. I've updated those styles to:

1. Keep the white color for simple links (tried a few different things, but nothing looked great).
2. For the "See how it works" button, keep the white color and use a one step darker Purple shade for the background.
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/46dabf9308d8
Visual tweaks to about:privatebrowsing; r=johannh
https://hg.mozilla.org/mozilla-central/rev/46dabf9308d8
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Assignee: nobody → florens
Hello,

I could not reproduced this issue using Fx 65.0a1, build ID: 20181108220756, on Windows 10 x86 and Ubuntu 18.04 x64.
I can confirm this issue is verified fixed using Fx 65.0b5, build ID:  20181217180946, on Windows 10 x32, macOS X 10.13 and Ubuntu 18.04.

I tried with different resolutions on both Windows and Ubuntu, the spacing looks good to me!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.