[MARGIN-C]{compat}text displayed outside floating div element

RESOLVED DUPLICATE of bug 150198

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 150198
16 years ago
15 years ago

People

(Reporter: lode leroy, Assigned: Marc Attinasi)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012 (r1.0)

Text inside a bordered floating DIV overlaps the text flowing around it, because
the first line is left empty

Reproducible: Always
Steps to Reproduce:
1.visit url
2.
3.

Expected Results:  The text should remain inside the boxes drawn around it

(this is the HTML that causes a problem)
<div style="width: 170; height: 64; float: right; border-style: ridge">

<p style='margin-left:0in;mso-layout-grid-align:none;
text-autospace:none'><i><b><font size="2">The aim of F# is to have a mixed 
functional-&nbsp; imperative language that works together seamlessly with C# and 
other .NET languages.</font></b></i></p>

</div>

Comment 1

16 years ago
Is the text rendering problem inside the divs in
http://www.worditude.com/ebooks/htmlbooks/vrabbit.html
related to this bug?

Using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.0) Gecko/20020530

adding CC

Updated

16 years ago
QA Contact: petersen → moied

Comment 2

16 years ago
Actually IE5.5 appears to blow this. Read

http://www.w3.org/TR/REC-CSS2/visudet.html#propdef-height and 
http://www.w3.org/TR/REC-CSS2/visufx.html#overflow

and see if that answers your question. [Um, there is the other thing
about margins not collapsing between <div><p> and I don't know offhand
whether that's a bug or not].
(Reporter)

Comment 3

16 years ago
What I was reporting actually works in IE 5.5.

What happens is that the height of the box around the floating paragraph is ok, 
but there is an empty line before the start of the text, and thus the last line
falls outside of the boxed floating paragraph.

so instead of:
+-----------+
|bla bla bla|
|bla bla    |
+-----------+

mozilla renders this
+-----------+
|           |  <--- the empty line I'm referring to
|bla bla bla|
+bla-bla----+

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3

Updated

16 years ago
Target Milestone: --- → Future

Comment 4

16 years ago
Seing this on Win 2000 and Mac OS 9 as well, the page renders correctly in 
Netcape 4.
Keywords: 4xp
OS: Windows NT → All
Hardware: PC → All
This seems like it's just like bug 33784, except for floats instead of table
cells.  (Margins don't collapse through borders.)
Summary: text displayed outside floating div element → [MARGIN-C]{compat}text displayed outside floating div element

Comment 6

16 years ago
*** Bug 151119 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
Check out bug 150198, that one has the same URL as this bug, but that one is a
Tech Evangelism bug.

Comment 8

15 years ago
*this* bug is a dupe of 150198

*** This bug has been marked as a duplicate of 150198 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Priority: P3 → --
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.