crash [@ java.lang.NullPointerException: at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.renameAccountIfNecessary(AndroidFxAccount.java)]

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
normal
VERIFIED FIXED
7 months ago
3 months ago

People

(Reporter: mirabela.lobontiu, Assigned: andrei.a.lazar)

Tracking

({crash})

Trunk
Firefox 66
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox64 wontfix, firefox65 verified, firefox66 verified)

Details

(crash signature, )

Attachments

(2 attachments)

Reporter

Description

7 months ago
Posted file logcat
Device:
 - Sony Xperia Z5 Premium (Android 6.0.1);
 
Build(s):
 - Nightly 65.0a1 (2018-11-07);
 - Release 63.0.2.

Steps to reproduce:
 1. Go to Settings -> Sign in, and sign in with valid credentials.
 2. Go to Settings -> you FxA and Disconnect
 3. Nightly crashes

Expected result:
 The user should be disconnected.

Actual result:
 Nightly crashes.
See Also: → 1349147
Reporter

Comment 1

7 months ago
Hi,

I reproduced the crash on Nightly 65.0a1 (2018-11-08) on Samsung Galaxy Note 8 (Android 8.0).

crash signature: [@ java.lang.NullPointerException: at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.renameAccountIfNecessary(AndroidFxAccount.java) ]
If we crash every time people log out of accounts we should set this as a P1 to investigate. 
It doesn't look like a huge crash volume on release, but it's significant.
Priority: -- → P1
Assignee

Updated

6 months ago
Assignee: nobody → andrei.a.lazar
Assignee

Comment 3

5 months ago
Refreshing account (triggered by signing in) can cause a NullPointerException after quickly signing out.
This defect consists in bad sync between the signing in state and signing out state.

Comment 4

5 months ago
Request from Janet to find a proper reviewer.
Flags: needinfo?(jdragojevic)
Hi,
I have just reproduced the crash with this id on the Sony Xperia Z5 with Android 7.0 on Fennec 64.0.1 - build id: 20181213132357
https://crash-stats.mozilla.com/report/index/aed7858f-d040-44da-96a6-edeba0181214#tab-details

Comment 6

5 months ago
@Susheel - both Edourard and Nick Alexander provided reviews for this fix.  

@Alexandru, it's unclear to me whether you reproduced this issue before or after the fix was merged.  

@Susheel, I'm NI'ing back to you to follow up on the details here.
Flags: needinfo?(jdragojevic) → needinfo?(sdaswani)
Assignee

Comment 7

5 months ago
Hey Janet, I am still working on this, nothing has been merged. Will make requested changes ASAP

Comment 8

5 months ago
Thanks Janet, Andrei is working on it so removing my NI until further 'needed' :) .
Flags: needinfo?(sdaswani)
Assignee

Updated

5 months ago
Keywords: checkin-needed

Comment 9

4 months ago

Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dfdec6abcc4d
crash [@ java.lang.NullPointerException: at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.renameAccountIfNecessary(AndroidFxAccount.java)] r=Grisha

Keywords: checkin-needed

Comment 10

4 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Assignee

Updated

4 months ago
Blocks: 1508600

Can you request uplift to 65 beta? It seems worth doing as it's ~1000 crashes/week on release.

Flags: needinfo?(andrei.a.lazar)
Assignee

Comment 12

4 months ago

Sure Liz, will do.

Flags: needinfo?(andrei.a.lazar)
Assignee

Comment 13

4 months ago

Comment on attachment 9030774 [details]
Bug 1505720 crash [@ java.lang.NullPointerException: at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.renameAccountIfNecessary(AndroidFxAccount.java)] r=JanH

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1505720

User impact if declined: Will continue to cause a lot of crashes.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce:

List of other uplifts needed: None

Risk to taking this patch: Medium

Why is the change risky/not risky? (and alternatives if risky): It is a bit risky because it impacts a pretty complex component.

String changes made/needed:

Attachment #9030774 - Flags: approval-mozilla-beta?

Comment on attachment 9030774 [details]
Bug 1505720 crash [@ java.lang.NullPointerException: at org.mozilla.gecko.fxa.authenticator.AndroidFxAccount.renameAccountIfNecessary(AndroidFxAccount.java)] r=JanH

[Triage Comment]
Hard to tell how much difference it's made on Nightly so far, but looks low-risk enough. Let's get it into 65.0b11 to see if there's a clearer improvement.

Attachment #9030774 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Tested on latest Nightly build (66.0a1- 2019/01/14) and Beta 65.0b11 with the affected devices:

  • Sony Xperia Z5 Premium (Android 6.0.1) and
  • Samsung Galaxy Note 8 (Android 8.0.0)
    Following the steps provided by Mira I couldn't reproduce the issue and I will set the bug to VERIFIED.
Status: RESOLVED → VERIFIED

Updated

4 months ago
No longer blocks: 1508600
Reporter

Updated

3 months ago
See Also: → 1508600
You need to log in before you can comment on or make changes to this bug.