In Comments: wrong count of "-"

RESOLVED INVALID

Status

()

Core
HTML: Parser
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: Joachim, Assigned: harishd)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

If there is the wrong count of "-" in comments,
Mozilla will NOT interpret this beein a comment.
e.g.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Draft//EN">
<HEAD>
<TITLE>ALDI-Nord</TITLE>
</HEAD>
<!------ Comment o.k -->
<!---- Commont seems to be not closed -->
This is NOT seen
<!---- Commont seems to be not closed -->
This is seen


Reproducible: Always
Steps to Reproduce:
Read a file that is:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Draft//EN">
<HEAD>
<TITLE>ALDI-Nord</TITLE>
</HEAD>
<!------ Comment o.k -->
<!---- Commont seems to be not closed -->
This is NOT seen
<!---- Commont seems to be not closed -->
This is seen


Actual Results:  This is seen 

Expected Results:  This is NOT seen 
This is seen 

It is an illegal comment said http://validator.w3.org/
but it is unknown to be illegal to many writers and shown as wanted on nearly
all browsers:
IE, Netscape 4x, Konquorer...

Comment 1

16 years ago
Using dashes in comments is illegal in strict mode (see
http://www.w3.org/TR/html4/intro/sgmltut.html#h-3.2.4)

--> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

14 years ago
*** Bug 246678 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.