Closed Bug 1506026 Opened Last year Closed Last year

Chromeless(no toolbar) after exit Customize mode

Categories

(Firefox :: Toolbars and Customization, defect, P1, trivial)

Unspecified
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox65 --- verified

People

(Reporter: alice0775, Assigned: mconley)

References

Details

Attachments

(1 file)

Steps To Reproduce:
1. Make browser normal sizemode
2. F11 to Fullscreen
3. Enter Customize
4. Click restore button in titlebar
5. Click [Done] to exit customize mode

Actual Results:
Chromeless, i.e. no toolbar(tab bar, nav bar, etc.)

Expected Results:
Toolbar should appears because browser is in normal sizemode.
Severity: normal → trivial
Hi Alice0775 White,

Can you please attach a screen recording of this issue? I can't reproduce it following the steps on Windows 10 x64, latest Nightly 65.0a1 (2018-11-12) (64-bit). I assume that you reproduced it on a clean profile and so on, can you confirm this?

Thanks
Flags: needinfo?(alice0775)
(In reply to Timea Babos from comment #1)
> Hi Alice0775 White,
> 
> Can you please attach a screen recording of this issue? I can't reproduce it
> following the steps on Windows 10 x64, latest Nightly 65.0a1 (2018-11-12)
> (64-bit). I assume that you reproduced it on a clean profile and so on, can
> you confirm this?
> 
> Thanks

Yes, I can reproduce with new profile.

Screen cast: https://youtu.be/9Z1nmi1-89w

Steps To Reproduce:
1. Make browser normal sizemode
2. Focus address bar   <---- this is needed to reproduce
3. F11 to Fullscreen
4. Enter Customize from hamburger menu
5. Click restore button in titlebar
6. Click [Done] to exit customize mode
Flags: needinfo?(alice0775)
That additional step was indeed the catch. Reproduced on Windows 10 x64 on latest Nightly 65.0a1 (2018-11-12) (64-bit).
Not quite sure about the component but Toolbars and Customizations might be a good start. Please move it to the correct one if this is not the one.

Thanks for the report and follow-up!
Component: Untriaged → Toolbars and Customization
Any chance this is a regression from the tabsintitlebar work?
Flags: needinfo?(mconley)
(In reply to :Gijs (he/him) from comment #4)
> Any chance this is a regression from the tabsintitlebar work?

Yeah, possibly. I'll investigate this.

I'm marking P1 because this seems like a fun way of breaking a whole browser window.
Assignee: nobody → mconley
Flags: needinfo?(mconley)
Priority: -- → P1
(In reply to :Gijs (he/him) from comment #4)
> Any chance this is a regression from the tabsintitlebar work?

Using mozregression, it looks like this problem existed before the tabsintitlebar work. So this isn't a very recent regression, as far as I can tell.

Still a pretty nasty bug though.
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b1c8590d5f74
Don't accidentally hide the navigator-toolbox if fullscreen has been exited. r=jaws
https://hg.mozilla.org/mozilla-central/rev/b1c8590d5f74
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Flags: qe-verify+

I reproduced this issue using Fx 65.0a1 Build ID 20181108220756, on Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx 65.0b11, build ID: 20190114172331, on Windows 10 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1523218
You need to log in before you can comment on or make changes to this bug.