Closed Bug 1506069 Opened 3 years ago Closed 3 years ago

Dialog to ask confirmation about closing tabs is opened when exiting Firefox, even if session restore is enabled

Categories

(Firefox :: Session Restore, defect)

65 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1506173
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- fixed

People

(Reporter: marco, Unassigned)

Details

(Keywords: regression)

Until a few days ago, when you closed Firefox and you had session restore enabled, Firefox would be closed silently.
Now, a dialog appears warning you that there are N tabs open and closing Firefox will close them.

The dialog only used to appear when session restore was disabled.
Daniel, you set this bug as affecting 63 and 64, can you reproduce the bug in these versions as well?
Flags: needinfo?(daniel.aschilean)
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=f6f47d5b05b68597739e059cc707573a3d1cea01&tochange=fd42da5a8e1a571a356f5a18d7417116dcb63389

Regressed by:
fd42da5a8e1a	Gijs Kruitbosch — Bug 550559 - also show close warnings when session restore is active, r=jaws,flod
Version: Trunk → 65 Branch
:Gijs
Your patch causes the regression. Can you please look into this?
Flags: needinfo?(daniel.aschilean) → needinfo?(gijskruitbosch+bugs)
There's a number of bugs on different facets of this topic and it's getting confusing trying to follow them, but from what I remember seeing in my bugmail in the last week or two:
1) This is intentional because people (mostly on Mac, where Cmd-W is close tab and Cmd-Q is quit, and they're next to each other on the keyboard) are quitting Firefox when they don't mean to, and then having to wait for session restore to do its thing when they restart it.
2) The generic dialog that already existed was used, when it probably should have been a new one that indicated things would be restored next time rather than lost.
3) There are two separate preferences (one for session restore, and one for the dialog box) and the dialog box one seems to be getting ignored, so if you have save session on quit enabled, but warn on quit disabled, you still get the dialog. Or vice versa, I forget which way around it is.
As Dave said, this is an intentional bug fix. It was an annoying bug to not be warned to close the entire browser with 400 tabs, and to have to reload all of them. Consequently, it was a very, very frequent user request to have this dialog. The fact that we have this dialog now made a lot of people happy.
FWIW, I want my tabs to be restored, but I do want to clear cookies on shutdown. I have to re-login everywhere. Even if cookies are kept, forms might have state that's not restored (I see this regularly that I accidentally close a single tab, do Ctrl-Shift-T to restore it, and my input data is gone), or the web page might show transient application state that is not restored on reload. So, closing all 400 tabs is a data loss action and needs the warning.
If it's intentional, I think it would make sense to specify in the dialog that the session will be restored.
(In reply to Alice0775 White from comment #3)
> :Gijs
> Your patch causes the regression. Can you please look into this?

As has already been said, this was an intentional choice, not a "regression". It's documented in the bug you referenced:

(In reply to Amy Lee [:amylee] UX from bug 550559 comment #52)
> (In reply to :Gijs (Not available 3-19 Aug; he/him) from bug 550559 comment #50)
<snip>
> > In your new design, we'd remove the hardcoded checks to ask session restore
> > in the code that actually implements warning, and cosmetically we'd move the
> > checkbox in about:preferences, and add some logic to tick/untick (and
> > set/unset the pref) when the user toggles restoring their session. But that
> > doesn't solve the conundrum here - the pref would be turned on by default,
> > and we'd remove the checks, so then the user will start getting warnings.
> > 
> > We could have a one-time migration that turns off the "warn when closing
> > tabs" pref for people who have session restore turned on, but that also
> > seems like it'd potentially confuse users who would no longer see warnings
> > when closing windows / multiple tabs (e.g. via "close tabs to the right")
> > where they did see those before.
> > 
> > What would you prefer we do? Disable the warnings everywhere for session
> > restore users, or accept that we'll now start warning session restore users
> > who might not have expected this?
> 
> I would say accept that we'll now start warning session restore users about
> quitting. They have the option on the warning message to disable it if they
> want to. I've changed the wording slightly in the preference to include
> "quitting" when enabling warning on closing multiple tabs. If a user quits
> the browser with multiple tabs opened they should get this warning as well
> cause technically they are still closing multiple tabs when quitting. I've
> attached an updated spec.


(In reply to Marco Castelluccio [:marco] from comment #7)
> If it's intentional, I think it would make sense to specify in the dialog
> that the session will be restored.

Yes, we're asking UX to come up for wording for this in bug 1506173.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 1506173
No longer blocks: 550559
You need to log in before you can comment on or make changes to this bug.