Closed Bug 1506114 Opened 2 years ago Closed 2 years ago

The library button displays a fading animation after bookmarking a webpage

Categories

(Firefox :: Theme, defect, P1)

65 Branch
All
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- verified

People

(Reporter: emilghitta, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image library.gif
[Affected versions]:
Firefox 65.0a1 (BuildId:20181108100100)

[Unffected versions]:
Firefox 64.0b7 (BuildId:20181105164654)
Firefox 63.0.1 (BuildId:20181030165643)
Firefox 60.3.0esr (BuildId:20181017185317)

[Affected platforms]:
Windows 10 64bit

[Steps to reproduce]:
1. Launch Firefox.
2. Bookmark any webpage and observe the library button.

[Expected result]:
The library button is not displaying a fading animation. 

[Actual result]:
The library button has a fading animation.

[Regression range]:
This seems to be a recent regression:

Last good revision: b9a0d600e885107a741ad7e98a9be6aeb0c6d2b4
First bad revision: a672ddc3be9ff55553aa5ffeead42a505e38bb94

Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=b9a0d600e885107a741ad7e98a9be6aeb0c6d2b4&tochange=a672ddc3be9ff55553aa5ffeead42a505e38bb94

[Notes]:
For further information regarding this issue, please observe the attached screencast.
Hi Dao,

It seems that mozregression pointed out Bug 1503022 for causing this regression.

Can you please have a look? 

Thanks!
Flags: needinfo?(dao+bmo)
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Component: Menus → Theme
Flags: needinfo?(dao+bmo)
Priority: -- → P1
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/781581f8c129
Move library-animatable-box into the navigation toolbar so it inherits the right color, and clean up related CSS. r=jaws
https://hg.mozilla.org/mozilla-central/rev/781581f8c129
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Depends on: 1506397
I have reproduced this bug with Nightly 65.0a1 (2018-11-09) on Windows 10, 64 Bit ! 

This bug's fix is Verified with latest Beta !

Build   ID    20181220174318
User Agent    Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

[testday-20181221]
Thank you Sajedul for verifying this issue.

Marking this accordingly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.