Addresses in status bar are displayed decoded (unescaped)

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
17 years ago
5 years ago

People

(Reporter: email, Assigned: bugzilla)

Tracking

({intl, regression})

Trunk
x86
Windows ME
intl, regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; de-AT; rv:1.0rc3) Gecko/20020523
BuildID:    2002052306

Hi,

Mozilla does not work taking over a string containing 
german umlauts (ה,�,צ) using the php-macro 'rawurlencode'. 
Netscape 6.1,6.2 and also IE have no problem concerning this.

example 

<?php
$text = rawurlencode('הה צצ ��');
echo "
<a
href=javascript:newWindow('./test.php?text=$text','','width=430,height=60,dependent=yes')
onClick=\"submit()\">
</a> ";

best regards 
Ingrid


-----------------------------------------------------------------------------------------
---------- enclosure: description rawurlencode -----------------------
rawurlencode

(PHP 3, PHP 4 )
rawurlencode -- URL-encode according to RFC1738
Description string rawurlencode ( string str)
Returns a string in which all non-alphanumeric characters except
-_. have been replaced with a percent (%) sign followed by two hex digits. This
is the encoding described in RFC1738 for protecting literal characters from
being interpreted as special URL delimiters, and for protecting URL's from being
mangled by transmission media with character conversions (like some email systems). 

--------------------- end manual rawurlencode ------------------------- 
-----------------------------------------------------------------------


Reproducible: Always
Steps to Reproduce:
1. editing the example 
2. 
3.

Comment 1

17 years ago
What does Mozilla have to do with PHP? Mozilla only gets the output.

Please provide testcase.

pi

Comment 2

17 years ago
url: http://alge.nlc.no/~alge/mozbug.php
it seems like the encoded text (%E4%E4%20%F6%F6%20%FC%FC) is decoded by mozilla.
which kind of defeats the purpose of using rawurlencode().

Comment 3

17 years ago
I think this is intended. The link is still correct, it only displays decoded.

That would make this bug INVALID.

pi
Summary: german umlauts (ä,ü,ö) using the php-macro 'rawurlencode' → Addresses in status bar are displayed decoded

Comment 4

17 years ago
This isn't string.

darin, jst, any idea if this belongs to one of you?

Comment 5

17 years ago
cc'ing nhotta

Comment 6

17 years ago
*** Bug 150690 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Looks like bug 60178. Dupe it there and reopen? Over to internatinalization. NEW
for a decision of QA.

pi
Assignee: jaggernaut → yokoyama
Status: UNCONFIRMED → NEW
Component: String → Internationalization
Ever confirmed: true
QA Contact: scc → ruixu

Updated

17 years ago
Keywords: intl, regression

Updated

17 years ago
QA Contact: ruixu → kasumi

Comment 8

17 years ago
nhotta: is this intended?
Assignee: yokoyama → nhotta
(Reporter)

Comment 9

17 years ago
Hi,

it's a pity that we can't use Mozilla for our intranet solution because of this
bug. Do you think the mozilla-team will solve this problem?
We are very interested in a solution.


regards ingrid
 

Updated

17 years ago
Summary: Addresses in status bar are displayed decoded → Addresses in status bar are displayed decoded (unescaped)

Comment 10

17 years ago
> url: http://alge.nlc.no/~alge/mozbug.php
> it seems like the encoded text (%E4%E4%20%F6%F6%20%FC%FC) is decoded by 
mozilla.
> which kind of defeats the purpose of using rawurlencode().

But looking at the info in the original bug report, it does not prohibit 
decoding it for UI display.
I tried http://alge.nlc.no/~alge/mozbug.php with IE 5 and IE 6, the URL was 
unescaped for status bar display.

Comment 11

17 years ago
.
Assignee: nhotta → blaker
Component: Internationalization → XP Apps: GUI Features
QA Contact: kasumi → paw
Whiteboard: DUPEME
ingrid, how is this bug a problem for you intranet?  This bug does not affect
anything mozilla does except what it shows in the status bar...

I'm failing to see what the bug is here, frankly...
This is a problem when you're developing websites and you'd like to be sure the
links you build are correct.  In previous versions of Mozilla I could just
mouseover and check the status bar.  Now I have to view source and find. 
Significantly less convienient.

Comment 14

15 years ago
Bill: right-click, copy link location (or properties).

IE does this too.  I think it's intentional, to help international users see
where they're going.

Comment 15

15 years ago
marking WONTFIX.  mozilla purposefully decodes any escape sequence in the URL
string that corresponds to a character in the document charset or UTF-8.  this
is done as Jesse said to improve the experience for international users.  the
decoded URL string is created only for display purposes.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Core → Mozilla Application Suite

Comment 16

14 years ago
*** Bug 295521 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.