Convert search-one-offs from a custom element to a plain JS class and initialize it lazily

RESOLVED FIXED in Firefox 65

Status

()

P1
normal
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: bgrins, Assigned: dao)

Tracking

(Blocks: 1 bug, {perf})

unspecified
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(1 attachment)

Right now we are doing work to create these nodes in DOMContentLoaded, but they aren't used until the popup is opened. See https://bugzilla.mozilla.org/show_bug.cgi?id=1506237#c1.

There's also been discussion about making this a plain JS class instead of a Custom Element: https://bugzilla.mozilla.org/show_bug.cgi?id=1493536#c6. It might make sense to do that as part of this lazifying.
(Assignee)

Updated

4 months ago
Assignee: nobody → dao+bmo
Blocks: 1477949
Status: NEW → ASSIGNED
Keywords: perf
Priority: -- → P2
(Assignee)

Updated

4 months ago
Blocks: 1505814
(Assignee)

Updated

4 months ago
Priority: P2 → P1

Comment 5

4 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/10a5af6d30df
Convert search-one-offs from a custom element to a plain JS class and initialize it lazily. r=bgrins

Comment 8

4 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1106b713fd95
Convert search-one-offs from a custom element to a plain JS class and initialize it lazily. r=bgrins
(Assignee)

Updated

4 months ago
Flags: needinfo?(dao+bmo)

Comment 9

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1106b713fd95
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
status-firefox65: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
(Assignee)

Updated

4 months ago
Blocks: 1492326
No longer blocks: 1505814
Summary: Make search-one-offs creation lazy → Convert search-one-offs from a custom element to a plain JS class and initialize it lazily
(Assignee)

Updated

4 months ago
Duplicate of this bug: 1505814
(Assignee)

Updated

4 months ago
Blocks: 1508585
(Assignee)

Updated

4 months ago
See Also: → bug 1508590
You need to log in before you can comment on or make changes to this bug.