Closed Bug 15063 Opened 22 years ago Closed 22 years ago

no one should be calling nsProfile::GetProfileDir() directly

Categories

(Core Graveyard :: Profile: Migration, defect, P3)

x86
All
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: sspitzer, Assigned: sspitzer)

References

Details

...except the file locator, which caches it.

find and fix all these cases.

http://lxr.mozilla.org/seamonkey/ident?i=nsIProfile
accepting.  marking all milestone 11.
almost fixed.

I just checked in the changes so that almost all callers of
nsProfile::GetProfileDir() have been converted to use the file locator service.

The exception is in some sidebar related js, and I'm working on that now.
*** Bug 14002 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
fixed.

the final caller in the sidebar js has been fixed.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.