Add support for optionally_keyed_by by-release-type to mozharness extra-options

VERIFIED FIXED in Firefox -esr60

Status

task
VERIFIED FIXED
6 months ago
5 months ago

People

(Reporter: bc, Assigned: tomprince)

Tracking

Trunk
mozilla65

Firefox Tracking Flags

(firefox-esr60 fixed, firefox65 verified)

Details

(Whiteboard: [stockwell fixed])

Attachments

(2 attachments)

Reporter

Description

6 months ago
After discussing the proposed patch in bug 1499352 attachment 9023986 [details] [diff] [review] with tomprince, we decided on the better approach would be to add the ability to optionally key the mozharness extra-options by release-type. It would support the ability to specify extra-options like:

raptor-tp6-1-firefox:
    description: "Raptor tp6-1 on Firefox"
    try-name: raptor-tp6-1-firefox
    treeherder-symbol: Rap(tp6-1)
    run-on-projects: built-projects
    max-run-time: 1800
    mozharness:
        extra-options:
            by-release-type:
                beta:
                    - --test=raptor-tp6-1
                    - --is--release-build
                release.*:
                    - --test=raptor-tp6-1
                    - --is--release-build
                esr.*:
                    - --test=raptor-tp6-1
                    - --is--release-build
                default:
                    - --test=raptor-tp6-1

Though, I wonder if projects would be an equivalent choice.

In the light of how verbose this would be and the fact it would be required on every test description I think I would just end up using 

if config.params['project'] in ('mozilla-beta', 'mozilla-release') or \
   config.params['project'].startswith('mozilla-esr'):
    extra_options.append('--is-release-build')

in https://searchfox.org/mozilla-central/source/taskcluster/taskgraph/transforms/tests.py#508

Feel free to wontfix this.
Flags: needinfo?(mozilla)
Assignee

Updated

6 months ago
Duplicate of this bug: 1506460
Comment hidden (Intermittent Failures Robot)
Since all occurrences are only on try based on OF, removing disable recommended tag.
Whiteboard: [stockwell disable-recommended]
Comment hidden (Intermittent Failures Robot)

Comment 8

6 months ago
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/a1fc429db01a
Remove unused branch_name passed from taskcluster to talos; r=jmaher
https://hg.mozilla.org/integration/autoland/rev/b1bec3572f17
Determine whether builds under test need signed extenions by release type; r=bc,ahal

Comment 9

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a1fc429db01a
https://hg.mozilla.org/mozilla-central/rev/b1bec3572f17
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Assignee: nobody → mozilla
Reporter

Comment 11

6 months ago
Thanks for taking this on Tom! I appreciate your proactive work on this.
Flags: needinfo?(mozilla)
Reporter

Comment 12

6 months ago
Tom: It appears --is-release-build is being set even for mozilla-central builds:
<https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=215084358&repo=mozilla-central&lineNumber=64-73>

Is there something different we need to do in order to only do it for beta, release or esr?
Flags: needinfo?(mozilla)

Comment 13

6 months ago
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f2833f7caddf
Fix typo in determining whether builds under test need signed extenions by release type; r=me
Assignee

Comment 14

6 months ago
There was a typo in the code to evaluate `require-signed-extensions`.
Flags: needinfo?(mozilla)
Reporter

Comment 16

6 months ago
Hah! I don't know how many times I must of looked at that patch and *never* saw it. Looks good now. Thanks!
Assignee

Comment 17

6 months ago
It took me grepping for the code that handled the 'by-release-type` and not finding it, to figure out that it was a typo. 😀
Reporter

Updated

5 months ago
Whiteboard: [stockwell disable-recommended] → [stockwell fixed]
You need to log in before you can comment on or make changes to this bug.