On a heavy page, mousing over the different icons on the tab-bar(download arrow, profiler button, library button, hamburger button etc) is janky

RESOLVED DUPLICATE of bug 1441308

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1441308
5 months ago
5 months ago

People

(Reporter: mayankleoboy1, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

1.enable WR
2. unzip the attachment (a large perf-html profile))
3. Go to https://perf-html.io/
4. Drag and drop the profile there
5. Wait till the profile loads
6. Mouse over the different icons on the tab-bar (download arrow, profiler button, library button, hamburger button etc)


Actual results:

The hover effect on the icons is laggy. CPU use is high (50% of my 2c/4T processor)

https://perfht.ml/2z4HoYa



Expected results:

not so
Heavy page content should not affect the animations of the UI
(Reporter)

Comment 1

5 months ago
maybe slightly better profile: https://perfht.ml/2OAVaGM

Also STR is a little modified:

Steps 1-5 are same
6. Show only the content process 3
7. Invert the callstack
8. Highlight the topmost function of the content (NTWaitforAlertByThreadID)
8. Mouseover the icons of the tab-bar 
OR
highlight different functions of the inverted stack list. The highlighting is also laggy
(Reporter)

Updated

5 months ago
See Also: → 1506437
(Reporter)

Updated

5 months ago
See Also: → 1506449
Priority: -- → P3
(Reporter)

Comment 2

5 months ago
Actually, this testcase is overly complicated. No need to all of that.
Will close this, and open a new bug with simpler testcase.
Also, this might just be the document splitting work.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

5 months ago
Simpler STR:

1. Go to Just go to https://ci.chromium.org/p/chromium/g/main/console?limit=500 , 
2. Put mouse cursor over the tab bar/the address bar
3. Let the page settle
4. Move ,ouse over the downloads/extensions/library icons.

Slow movement.
Summary: On a heavy per-html page, mousing over the different icons on the tab-bar(download arrow, profiler button, library button, hamburger button etc) is janky → On a heavy page, mousing over the different icons on the tab-bar(download arrow, profiler button, library button, hamburger button etc) is janky
(Reporter)

Updated

5 months ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: document-splitting
You need to log in before you can comment on or make changes to this bug.