Changes panel should stay left to right even in RTL builds

RESOLVED FIXED in Firefox 65

Status

defect
P2
normal
RESOLVED FIXED
7 months ago
6 months ago

People

(Reporter: pbro, Assigned: rcaliman)

Tracking

unspecified
Firefox 65
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

7 months ago
STR:
- use a RTL build of Firefox Nightly
- open the inspector
- make CSS changes in the rule view
- look at the Changes panel (see screenshot)

Expected: changes are displayed like CSS rule in the rules-view, so should stay left-to-right, because that's how CSS writes, whatever the locale.

Actual: the changes are trying to display themselves right to left, but that doesn't make much sense since they are displayed as CSS.
Reporter

Comment 1

7 months ago
By adding something like this to the CSS, the UI reverts to LTR:

#sidebar-panel-changes .rule {
    direction: ltr;
}
Assignee

Updated

7 months ago
Blocks: 1503920
No longer blocks: track-changes
Priority: -- → P2
Assignee

Updated

7 months ago
Duplicate of this bug: 1506270
Assignee

Updated

6 months ago
Assignee: nobody → rcaliman
Status: NEW → ASSIGNED

Comment 4

6 months ago
Pushed by rcaliman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/215654db940b
Enforce LTR code on RTL layout in Changes panel r=pbro

Comment 5

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/215654db940b
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.