SSL login-fails strangely

RESOLVED DUPLICATE of bug 145959

Status

()

Core
Security
--
major
RESOLVED DUPLICATE of bug 145959
16 years ago
16 years ago

People

(Reporter: Mark Lord, Assigned: Mitchell Stoltz (not reading bugmail))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529
BuildID:    2002052918

Unable to complete the secure login sequence.  Have to resort to ANY other
browser (Netscape 4.xx works fine) instead of mozilla.

Broken, big time -- this used to work a few months ago.

Reproducible: Always
Steps to Reproduce:
1.Go to the URL shown, 
2.Enter 1234567812345678 as the "card number" (not a valid account, but it
really makes no difference).
3.Enter 12345678 as the "password".
4. Click on "Sign In".

Actual Results:  Instead of an "invalid login" message, the browser goes to:
http://www.cibc.com/solution/service/pers/home.jsp?BV_UseBVCookie=Yes&locale=en_CA&fullFrame=


Expected Results:  Should give an "invalid login" message: 
https://www.cibc.com/solution/service/pers/pcb/scripts/SignOn.jsp

Or if a valid account is used, it should login the user.  Both fail.

Try it and gather any information you want.  This used to work fine back around
(I think) M14 or thereabouts.

Pity.  Of the only two sites for which I require secure login, neither now work
with mozilla (the other was ingrammicro.ca).  Back to NS4.79 I guess.

Good Luck.

Comment 1

16 years ago
This is a duplicate of bug 145959
"CIBC online banking no longer allows login"

Reassigning to Security:General for parity with the duplicate bug.
Assignee: rogerl → mstoltz
Component: JavaScript Engine → Security: General
QA Contact: pschwartau → bsharma

Comment 2

16 years ago
Resolving as Duplicate. Mark, thank you for this report. You have
been cc'ed on bug 145959 so you may follow its progress. 

If you have any further news about this site, please add the 
comments to bug 145959; thanks -

*** This bug has been marked as a duplicate of 145959 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.