DOM Inspector does not display captured image

VERIFIED WONTFIX

Status

Other Applications
DOM Inspector
VERIFIED WONTFIX
16 years ago
10 years ago

People

(Reporter: jsp, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020609
BuildID:    2002060908

After DOM Inspector is used to capture an image of part or all of a page, the
captured image does not display in the area apparently reserved for it. If I
select Pick Color... and mouse over the image area, plausible color values
appear in the picker.

Reproducible: Always
Steps to Reproduce:
1. Start DOM Inspector. If the document tree is empty, load a page to populate it.
2. Select a node that displays something in the tree.
3. In the "Object" pane (or tab, if using the sidebar version), select "Box
Model," then click "Capture" under "Image."

Actual Results:  The image display area remains as it was before the capture
(solid gray in my case), except that it may acquire a horizontal scroll bar.

Expected Results:  I expected the image area to display the captured image.

I wonder if this is dependent on the display driver in use. As far as I can
tell, no one else has reported this, though there are other bugs filed about the
capture feature.

This seems to occur with any page. The problem manifests with Moz 1.0 as well.
(Reporter)

Comment 1

16 years ago
I tried turning off my video driver's hardware acceleration. It didn't make any
difference. Nor did changing the display resolution.

Comment 2

16 years ago
After a capture, if I check "Show Boxes" and "Fill Boxes" I see a blue square
with a red border the size of the image captured. (2002061104, win2k)

Comment 3

15 years ago
well I can't find a dupe of this, and I can reproduce it with trunk 2002080208
on win2k, so confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
I get this too - nothing but gray.  Additionally, if I hit CAPTURE and then PICK
COLOR, the color picker is actually picking up the colors from the image - as
though the image were there.

Seeing it on multiple machines - Win2k build 2002100204 AND WINXP build 2002100604.

Comment 5

15 years ago
This would be an incredibly useful feature (DOM Capture) for web site developers
as well as users (to report problems) if it were working properly!

Comment 6

15 years ago
bug is still here in mozilla 1.3 release :(

Comment 7

15 years ago
wontfixing this bug, since the checkin for bug 210096 removed the feature this
bug was pertinent to. If this assessment is incorrect, please reopen.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 8

15 years ago
vrfy wont
Status: RESOLVED → VERIFIED
Product: Core → Other Applications
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.