Closed Bug 1506513 Opened Last year Closed Last year

[remote-dbg-next] Could not inspect any worker

Categories

(DevTools :: about:debugging, enhancement, P1)

enhancement

Tracking

(firefox65 fixed)

RESOLVED FIXED
Firefox 65
Tracking Status
firefox65 --- fixed

People

(Reporter: daisuke, Assigned: daisuke)

References

(Blocks 1 open bug)

Details

(Whiteboard: old-remote-debugging-ng-m3)

Attachments

(2 files)

An error occur from JavaScript as below when click the inspect button for any workers.

```
JavaScript error: resource://devtools/client/framework/devtools-browser.js, line 384: TypeError: client.attachWorker is not a function
```

STRs:
1. Open about:debugging
2. Click an inspect button of a worker

ER:
Can inspect.

AR:
An error occurred.

This seems caused by bug 1497917.
We introduced client-wrapper from the bug, though gDevToolsBrowser.openWorkerToolbox expect debugger-client, we are sending client-wrapper. 
https://searchfox.org/mozilla-central/source/devtools/client/aboutdebugging-new/src/actions/debug-targets.js#65
Priority: -- → P2
filter on remote-debugging-next-move-m3-to-m2
filter on remote-debugging-next-move-m3-to-m2
filter on remote-debugging-next-move-m3-to-m2
No longer blocks: remote-debugging-ng-m3
Whiteboard: old-remote-debugging-ng-m3
Assignee: nobody → dakatsuka
Status: NEW → ASSIGNED
Priority: P2 → P1
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62dd0d1a37b7
Use clientWrapper instead of client. r=jdescottes
https://hg.mozilla.org/integration/autoland/rev/7b9332b0c24d
Add worker mock test. r=jdescottes
https://hg.mozilla.org/mozilla-central/rev/62dd0d1a37b7
https://hg.mozilla.org/mozilla-central/rev/7b9332b0c24d
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.