Edit/Preferences and Search Sidebar gone

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Oliver Kluge, Assigned: Matti)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
While surfing on Bugzilla I noticed that all of a sudden my Search sidebar went
away, being replaced by a yellow window containing the text

<button id="searchButton" label="&search.button.label;"
--------^

I wanted to check into Edit / Preferences to re-select Google search, just to
see that Edit / Preferences is gone as well obviously showing some Chrome innards...
I will make a screenshot, as I cannot copy and paste from that window.

This does not seem to be a duplicate of 136040 (taskbar disappearing because
overlays.rdf gets overwritten), the taskbar is still there as well as the "Block
images from this server" context dialog.
(Reporter)

Comment 1

16 years ago
Created attachment 87106 [details]
Screenshot of the window that now appears instead of Edit / Preferences
(Reporter)

Updated

16 years ago
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 2

16 years ago
The effect of the bug is reversible, after terminating and restarting Mozilla
both the Search sidebar and Edit / Preferences are back to normal.

I'll have to see whether I can reproduce this bug. Just before it happened, I
surfed Bugzilla.

Comment 3

16 years ago
This type of page is indicating parsing errors in the XML. Not sure how it would 
have happened...
(Assignee)

Comment 4

16 years ago
please don't touch the Target Milestone or Priority fields, thanks
Target Milestone: mozilla1.0 → ---
(Assignee)

Comment 5

16 years ago
Can you try to delete/rename the file "component.reg" in your mozilla binary
directory ?
(Reporter)

Comment 6

16 years ago
No visible changes at all. Mozilla created a new filecomponent.reg, and while it
was running, it did not flush it's buffers, so the file remained open and at 0
bytes. Once I close Mozilla, the content was written. It is binary identical to
the component.reg I removed from the directory.
(Assignee)

Comment 7

16 years ago
Can you please do this :
uninstall mozilla, delete all files in your mozilla binary directory and
reinstall mozilla.
(Reporter)

Comment 8

16 years ago
What exactly do you mean by "uninstall"? To my knowledge there is no way to
uninstall Mozilla on OS/2. I can delete all of the files, if that is what you
meant. Do you want me to delete all of Mozilla's files or just the ones in the
bin directory?

Comment 9

16 years ago
just the ones in the bin directory and the directories under it.

Have you been able to recreate this since it happened?

Comment 10

16 years ago
If you find a scenario that create this problem, please reopen
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

16 years ago
Deleting and re-installing Mozilla did not change anything. So far I have not
seen the bug appear a second time.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.