Closed Bug 1506661 Opened 1 year ago Closed 1 year ago

[remote-dbg-next] Support Manifest URL link for addon targets with Remote Runtimes

Categories

(DevTools :: about:debugging, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1488509

People

(Reporter: jdescottes, Unassigned)

References

(Blocks 1 open bug)

Details

When debugging local This Firefox, all addon targets propose a "Manifest URL" link which will open the manifest file for the addon in a new tab, with a URL such as

  moz-extension://b293e463-481e-5148-a487-5aaf7a130429/manifest.json

For remote runtimes, such URLs will not work on another firefox instance (unless it has the same addon installed maybe?). In bug 1495381 I propose to simply hide the feature for runtimes other than This Firefox.

The goal of this bug is to decide if the feature should remain available only to This Firefox, or if we can find a way to bring it to remote runtimes.
Ugh I already filed this as Bug 1488509...
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1488509
You need to log in before you can comment on or make changes to this bug.