Closed Bug 1506825 Opened 4 years ago Closed 3 years ago

Salesforce.com is not loaded while CB is ON

Categories

(Web Compatibility :: Desktop, defect, P1)

Firefox 65
Desktop
Windows 10
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sergiu, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [tp-ads][enterprise])

User Story

salesforce.com
Environment:
Operating system: Windows 10 Pro
Firefox version: Firefox Nightly 65.0a1 (2018-11-12) (64-bit)

Prerequisites:
Enable Basic Tracking Protection

Steps to reproduce:
1. Navigate to: https://na85.lightning.force.com/lightning/setup/SetupOneHome/home
2. Login withvalid credentials.

Expected Behavior:
The site is loaded.

Actual Behavior:
The site remains in a loading state.

Notes:
1. Screenshot attached: http://prntscr.com/lhss4z
This is related to `trackingprotection` breakage #1101005

Looking at the devtools console, here are the blocked resources:

The resource at “https://static.na85.salesforce.com/auraFW/javascript/E2OJpiob8DqmgDSgi4K91g/aura_prod.js” was blocked because tracking protection is enabled.[Learn More]

So these are the domains to test:
salesforce.com

I opened the URL in a fresh browser profile (Firefox Nightly 63, uMatrix installed, normal mode) and loaded the page. The page did not fully load.

I disabled the Spoof Referrer option in uMatrix and then *WHITELISTED*:
salesforce.com

After this, the page loaded.
The other resources didn't help.

http://prntscr.com/lhsuha

salesforce.com can be found in the disconnect-blacklist.json and disconnect-entitylist.json

So in conclusion:
salesforce.com - Advertising = [tp-ads]
Whiteboard: [tp-ads]

Still affecting 66.0b4.

Product: Tech Evangelism → Web Compatibility
Whiteboard: [tp-ads] → [tp-ads][enterprise]

We think that https://github.com/disconnectme/disconnect-tracking-protection/pull/93 will fix this issue and I've reached out to a contact at Cisco to discuss and verify.

UPDATE: Actually I meant to post this comment in https://bugzilla.mozilla.org/show_bug.cgi?id=1586576 and I'm not sure the Disconnect update will fix this issue, but we'll look into it further.

Sergiu, can you please confirm if this issue is now fixed?

Flags: needinfo?(sergiu.logigan)

Hey Romain,

Yes, looks like the issue has been fixed.
http://prntscr.com/qkby5a

Tested with:
Browser / Version: Firefox Nightly 74.0a1 (2020-01-06)
Operating System: Windows 10 Pro

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(sergiu.logigan)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.