Closed Bug 1506835 Opened 9 months ago Closed 9 months ago

The buttons under the languages list are not visible if several languages are added to the list

Categories

(Firefox :: Preferences, defect, P2)

65 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- verified

People

(Reporter: george.craciun, Assigned: mstriemer)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Preconditions
Set the following preferences from about:config

intl.multilingual.enabled - set to TRUE
intl.multilingual.downloadEnabled - set to TRUE
Go to extensions.getAddons.langpacks.url and past the following link: https://mock-amo-language-tools.glitch.me/ This server provides language packs for Nightly.
extensions.langpacks.signatures.required -set to FALSE
Restart the browser.

[Affected versions]:

Tested on Nightly 65.0a1(2018-11-13)

[Affected platforms]:

All

[Steps to reproduce]:


1. Open "Preferences" and go to the "Language" section
2. Expand the language drop-down and choose Search for more languages..." option
3. Add several languages to the list


[Expected result]:

The buttons (Help/Cancel/OK) under the list are displayed correctly. 

[Actual result]:

The buttons (Help/Cancel/OK) under the list are pushed down and not visible anymore. Please see the attached print screen.
Mark, can you set a priority here?
Flags: needinfo?(mstriemer)
Flags: needinfo?(mstriemer)
Priority: -- → P2
Assignee: nobody → mstriemer
Attachment #9027688 - Attachment description: Bug 1506835 - Ensure browser languages dialog doesn't resize r?jaws → Bug 1506835 - Resize browser languages dialog when error apepars r?jaws
Attachment #9027688 - Attachment description: Bug 1506835 - Resize browser languages dialog when error apepars r?jaws → Bug 1506835 - Resize browser languages dialog when error appears r?jaws
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5f0040d4be16
Resize browser languages dialog when error appears r=jaws
https://hg.mozilla.org/mozilla-central/rev/5f0040d4be16
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
I verified this on Windows 10 x64, Mac OS X 10.14, Ubuntu 16.04 with the latest FF Nightly 65.0a1(2018-12-02) and I can't reproduce the issue. I will mark it as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.