Closed Bug 1506869 Opened Last year Closed Last year

Find bar buttons have lost their styling on Mac

Categories

(Firefox :: Theme, defect, P1)

Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox 66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- verified
firefox66 --- verified

People

(Reporter: dao, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(1 file)

From bug 1505847 comment 4:

> This change removed the hover/checked/active states from the findbar buttons
> on macOS.
> 
> There's this rule that needed to be taken care of:
> https://searchfox.org/mozilla-central/source/browser/themes/osx/browser.
> css#211-216
Summary: Find bar buttons lost their styling on Mac → Find bar buttons have lost their styling on Mac
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Hey Dao, have you had a chance to work on this?
Flags: needinfo?(dao+bmo)
I'm on the road and only have my Linux + Windows laptop with me. I can put up a patch if somebody wants to test it on Mac, otherwise this will have to wait till after the all hands.
Flags: needinfo?(dao+bmo)
Dao, ping since it's after all-hands.  Thanks
Flags: needinfo?(dao+bmo)
Flags: needinfo?(dao+bmo)
I can confirm this fixes the issue locally without any regression.
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bcfa9b966592
Don't remove .findbar-button's background-color set by toolbarbutton-icons.inc.css. r=jaws
Dao, can you please land a followup to change the names as requested in my review?
Flags: needinfo?(dao+bmo)
https://hg.mozilla.org/mozilla-central/rev/bcfa9b966592
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Possibly related to bug 1512586.
Duplicate of this bug: 1512586
Comment on attachment 9031386 [details]
Bug 1506869 - Don't remove .findbar-button's background-color set by toolbarbutton-icons.inc.css. r=jaws

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1505847

User impact if declined: Invisible findbar button ("Highlight all", "Match case", "Whole words") states

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?:

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Simple CSS fix.

String changes made/needed: None
Attachment #9031386 - Flags: approval-mozilla-beta?
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3ead21c6776b
Rename roundButtonBackground and roundButtonPressedBackground. r=jaws
Flags: needinfo?(dao+bmo)
Comment on attachment 9031386 [details]
Bug 1506869 - Don't remove .findbar-button's background-color set by toolbarbutton-icons.inc.css. r=jaws

[Triage Comment]
Minor CSS fix, approved for 65.0b5. Will take both patches for consistency as well.
Attachment #9031386 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
I have managed to reproduce this issue on an affected Firefox 65.0b4 build using macOS 10.14.  

This issue is verified fixed using Firefox 65.0b5 and Firefox 66.0a1 (BuildId 20181217093726).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
This is indeed fixed. Thank you!
You need to log in before you can comment on or make changes to this bug.