Changes panel visible even when pref is off

RESOLVED FIXED in Firefox 65

Status

defect
P1
normal
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: rcaliman, Assigned: rcaliman)

Tracking

unspecified
Firefox 65
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

(Whiteboard: [good first verify])

Attachments

(1 attachment)

(Assignee)

Description

5 months ago
STR:

- Go to about:config
- Flip this pref to FALSE:
devtools.inspector.changes.enabled
- Open a DevTools > Inspector

Expected:
Changes panel is not available

Actual:
Changes panel is visible.
(Assignee)

Updated

5 months ago
Blocks: 1503925
(Assignee)

Comment 1

5 months ago
The patch for Bug 1502857 accidentally removed the pref guard for the Changes panel. This patch reintroduces it.

This patch also addresses Bug 1503925 - Reposition Changes tab in Inspector sidebar to be right after Computed tab.

Comment 3

5 months ago
Pushed by rcaliman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/22c78747446d
Show Changes tab only when pref is on; r=pbro

Comment 4

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/22c78747446d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
(Assignee)

Updated

5 months ago
Duplicate of this bug: 1503925
Whiteboard: [good first verify]

Comment 6

3 months ago

I have reproduced this bug with Nightly 65.0a1 (2018-11-13) (64-bit) on Windows 10. This bug's fix is verified with latest Beta 65.0b10

Build ID - 20190110221328
User Agent - Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

[testday20190111]

You need to log in before you can comment on or make changes to this bug.