tfp.com - Error with action buttons

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: David A. Cobb, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
On the cited page, at the top, is a bar [Home | News | ContactUs | OrderForm |
Jobs].

Using the Evil Empire Browser: Click on Jobs, a small menu (one item, #TFP,
drops down), clicking on the dropdown takes me to a jobs page.

Using Mozilla: Click on jobs, the status bar shows "contacting www.tfp.com" and
nothing else happens.  If I view source, there is a paragraph:

<script LANGAUAGE=JAVASCRIPT> <!**** NOTE MIS-SPELLING 'LANGUAGE' -- SuperB !>

function openWin( windowURL, windowName, windowFeatures ) { 
      return window.open( windowURL, windowName, windowFeatures ) ; 
} 

</SCRIPT>

I do not see this at all in the E.E.B.  The site could be serving differently
depending on the browser' however, I believe our 'source' is reconstructed and
this is a strange thing to come up with.

Comment 1

16 years ago
Reassigning to Browser-General until we can get further information;
this is not likely to be a bug in JavaScript Engine. cc'ing self.

I tried a small test script with the above mis-spelling: 

<script LANGAUAGE=JAVASCRIPT>
alert("hi!");
</SCRIPT>

This runs fine, so that's probably not the problem. 


David:

1. I tried going to http://www.tfp.com/ in both IE6 and Mozilla,
   and got a 404 - File Not Found error. Is there a typo in the URL?

2. What build ID of Mozilla are you using? Please include that 
   in any bug report; thanks -

3. Are there any errors in the JavaScript Console? 
   (Tasks > Tools > Web Development > JavaScript Console)

   Be sure to clear it of any previous errors first -

4. What happens if you add this line to your Mozilla "user.js" file,
   in order to spoof as IE6? Note: do not include the carriage return
   that Bugzilla puts in due to space limitations:

user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 6.0; 
Windows NT 4.0)");
Assignee: rogerl → Matti
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → imajes-qa
(Reporter)

Comment 2

16 years ago
Responding to Phil:

1. I tried going to http://www.tfp.com/ in both IE6 and Mozilla,
  and got a 404 - File Not Found error. Is there a typo in the URL?

No, in fact I just clicked the above in my mail window and Voila! the home page
for Thompson Financial Publishing

2. What build ID of Mozilla are you using? Please include that   in any bug
report; thanks -

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020607 {Build
ID 2002060704}
Sorry, but I thought the Bugzilla page captured that automagically.  It says it
does so.

3. Are there any errors in the JavaScript Console?   (Tasks > Tools > Web
Development > JavaScript Console)

No, nothing there

  Be sure to clear it of any previous errors first -

4. What happens if you add this line to your Mozilla "user.js" file,
  in order to spoof as IE6? Note: do not include the carriage return
  that Bugzilla puts in due to space limitations:

user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 6.0;
Windows NT 4.0)");

Makes no difference
(Reporter)

Comment 3

16 years ago
Invading the heart of the Evil Empire, I find the following page:

http://www.microsoft.com/windows95/downloads/contents/WURecommended/S_WUServicePacks/MFCLibrary/Default.asp

The blue "Download Now" button doesn't respond (and no cursor change in mouseover).

Comment 4

16 years ago
From view-source:http://www.tfp.com/generic1.js:

                   NS4 = (document.layers);
                   IE4 = (document.all);
                  ver4 = (NS4 || IE4);   
                 isMac = (navigator.appVersion.indexOf("Mac") != -1);
                isMenu = (NS4 || (IE4 && !isMac));


Note that |document.layers| and |document.all| are non-W3C extensions
of DOM syntax. The former is an NN4.x proprietary feature, and the 
latter is an IE proprietary feature.

Mozilla/N6/N7 supports neither of these extensions. Thus, in the
code above, the variable |isMenu| gets set to |false|, and that's 
why the menu doesn't work at the site.

Note the site also uses outdated Macromedia template functions, such as:

function MM_findObj(n, d) { //v3.0
  var p,i,x;  

  if(!d) d=document;

  if((p=n.indexOf("?"))>0&&parent.frames.length) {
    d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);
  }

  if(!(x=d[n])&&d.all)
    x=d.all[n];

  for (i=0;!x&&i<d.forms.length;i++)
    x=d.forms[i][n];

  for(i=0;!x&&d.layers&&i<d.layers.length;i++)     
    x=MM_findObj(n,d.layers[i].document);

  return x;
}


This function does not work in Mozilla/N6/N7 beause it, too,
depends on |document.layers| or |document.all|. Version 4.0
or higher of this function is required -


Reassigning to the Tech Evangelism component, which will try to 
contact the site and encourage them to use W3C standards -
Assignee: Matti → doron
Component: Browser-General → US General
Product: Browser → Tech Evangelism
QA Contact: imajes-qa → zach
Version: other → unspecified

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Error with action buttons → [LAYER]Error with action buttons

Updated

16 years ago
Blocks: 51020
Summary: [LAYER]Error with action buttons → tfp.com - Error with action buttons

Comment 5

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 6

14 years ago
looks like they upgraded dw. -> fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.