Closed Bug 1507106 Opened 2 years ago Closed 2 years ago

Add atomic.notify as an alias for atomic.wake


(Core :: Javascript: WebAssembly, enhancement, P3)




Tracking Status
firefox65 --- fixed


(Reporter: lth, Assigned: lth)


(Blocks 1 open bug)


(Keywords: dev-doc-needed)


(1 file)

An extended bikeshedding session at the Wasm CG video call on Nov 13 decided, in the end, that we will rename atomic.wake as atomic.notify to track what JS is doing and because "wake" and "wait" sound too similar for comfort and tend to confuse listeners.  (Also lots of languages use "notify"; "wake" is a futexism.)

For the time being, let's just add an alias and not worry overmuch about updating everything else.
Attachment #9025002 - Flags: review?(jseward)
Comment on attachment 9025002 [details] [diff] [review]

Review of attachment 9025002 [details] [diff] [review]:

Sigh (re bikeshedding etc), although I do think notify is a better name.

Yes.  Looks fine.
Attachment #9025002 - Flags: review?(jseward) → review+
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Not sure if this is an internals thing, or if it is exposed to web devs. Will investigate soon.
Keywords: dev-doc-needed
Well...  those few people who manipulate textual webassembly (essentially compiler writers) will be exposed to this, but it's not a JS API, it's the name of the instruction when you write wasm text.  And the browser has no means of translating wasm text to wasm binary.  So technically it's not a web API.
OK, that makes sense; I still ought to mention it in (and generally update) the guide to WebAssembly text format on MDN, so I'll keep the dev-doc-needed keyword, but I won't include a note in the Fx65 rel notes.
You need to log in before you can comment on or make changes to this bug.