Closed Bug 1507177 Opened Last year Closed Last year

Thunderbird corrupts msword files (.doc and .docx)

Categories

(Thunderbird :: Untriaged, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1506800

People

(Reporter: mgehlen, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

MacOS 10.11.6
Office Word for MAC 2011

Since the installation of Thunderbird 60.3. (09.Nov.2018) attached word files (.doc and .docx) are corrupted. They cannot be opened in WORD - instead offer different converters in a separate small window. Servers from companies refuse the mail alltogether. (Diagnostic-Code: smtp;554 5.6.0 Corrupt message content; STOREDRV.Deliver.Exception:ConversionFailedException.MimeException; Failed to process message due to a permanent exception with message The message content has become corrupted. MimeException: MIME content error: Wrong magic number in Apple MIME attachment. [Stage: PromoteCreateReplay])
All other formats work fine – rtf, jpg, pdf, txt etc.-  doc or .docx with zip works also fine
doc. and docx. files from Thunderbird 52 to Tunderbird 60.3 can be opened without problem



Actual results:

mimeTypes.rdf deleted: no solution
Virus Scanner disabled and removed: no solution
In the corrupted .doc attachments the correct mime type „application/msword“ is replaced by mime type „multipart/appledouble“ or is deleted entirely.
The previous version Thunderbird 52 on a second MacBook works absolutely fine. The problem occurs with all four different mail accounts under Thunderbird 60.3.



Expected results:

The mime encoding seems not working properly.
Looks like for some reason we don't understand yet, TB 60 sends the documents in Apple-double format (when TB 52 didn't do that).

We haven't been able to reproduce this but we're thinking about complete removal of Apple-double encoding in bug 1506800.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1506800
You need to log in before you can comment on or make changes to this bug.