Closed Bug 1507185 Opened Last year Closed 11 months ago

Selected elements in Inspector disappearing from tree after reload

Categories

(DevTools :: Inspector, defect)

64 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1506792

People

(Reporter: andrew, Unassigned, NeedInfo)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

OSX Sierra, Developer Edition, since 64.0b5, still occurring with 64.0b9. During development of a web page. Load the page, open developer tools. Select an element with either pointer tool or 'Inspect element' on the context menu. Element is highlighted in tree view and properties can be inspected.
(work on HTML or CSS outside of the browser, usually for at least 30seconds)
Reload page.


Actual results:

Page reloads and displays any HTML or CSS changes okay. However the child elements of the selected element (sometimes the selected element itself) in the inspector panel has disappeared from the tree. Using the pointer tool to select the element on the page results in nothing being highlighted in the tree.
Will sometimes reappear after reload or shift-reload, but often another element must be selected and the page reloaded before the original elements reappear.


Expected results:

Previously selected element remains highlighted in the inspector tree view and child elements are not missing.
Andrew could you please create and attach a reduced testcase which ilustrates the issue so we can reproduce the issue on our side?
Flags: needinfo?(andrew)
Component: Untriaged → Inspector
Product: Firefox → DevTools
A reduced test case would really help. It sounds a bit it's related to bug 1506792 which was recently fixed.

@Andrew, are there by any chance ::before/after elements on your div?
See Also: → 1506792
Closing on suspicion that this was closed by bug 1506792. Please re-open if it still happens.
Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1506792
You need to log in before you can comment on or make changes to this bug.