Conn: Mac OS X - DNS failure or connection failure on auto-connect

VERIFIED WORKSFORME

Status

()

Core
Networking
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: benc, Assigned: gordon)

Tracking

({helpwanted, topembed+})

Trunk
mozilla1.3beta
PowerPC
Mac OS X
helpwanted, topembed+
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: notChimera)

(Reporter)

Description

16 years ago
Mozilla 1.0, Mac OS X

This maybe PPPOE specific, I have not tested normal dialup yet.

STEPS:

1- Start w/ Macintosh disconnect from DSL network, but with "Connect
Automatically" set for PPPOE.

(PPP is off)
[localhost:html/quality/networking] benc% ifconfig ppp0
ppp0: flags=8011<UP,POINTOPOINT,MULTICAST> mtu 1500
        inet 10.64.64.64 --> 10.112.112.112 netmask 0xff000000 
(offline resolver settings)
[localhost:html/quality/networking] benc% more /etc/resolv.conf
nameserver 10.112.112.112
nameserver 10.112.112.112

2- Open Internet Connect so you can see the status of the connection.
3- Run mozilla, watch it say "resolving www.mozilla.org" 

4-See Internet Connect make PPP connection and update nameserver list.

[localhost:html/quality/networking] benc% ifconfig ppp0
ppp0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1492
        inet 66.32.63.91 --> 66.32.63.1 netmask 0xff000000 

[localhost:html/quality/networking] benc% more /etc/resolv.conf
nameserver 207.69.188.186
nameserver 207.69.188.185

OBSERVED BEHAVIOR:

Mozilla will timeout w/ a DNS error for www.mozilla.org.

Hit reload, or anything else that causes another DNS Lookoup.

Mozilla lookup sucessful, works.

EXPECTED BEHAVIOR:
Mozilla should be refreshing the DNS list on a DNS error and attempt a lookup again.

NOTES:
I've looked at how this works w/ other utilities, like ping and nslookup. Apple
has this working in Mail.app.

I think this works for some people because they might have a fixed DNS entry
that points to a real nameserver on the internet BEFORE they dialup. If so, then
your connection attempt would cause a DNS lookup, which would cause the
connection to come up and then allow you to hit the right DNS server w/o having
to refresh the list.
(Reporter)

Comment 1

16 years ago
Okay, I did a lot more looking at this, and was surprised at what I found.

Even w/ IP addresses, an error occurs. So, in summary, the auto-connect feature
kicks the dialup event, but the initial networking call is not wrapped so that
new connection solves the networking request. Instead, you have to error and
wrap this in your application.

I'm going to do some looking on the Apple site and see if I can understand this
better.

+helpwanted, nsbeta - This really needs to be addressed.
Keywords: helpwanted, nsbeta1
OS: Mac System 9.x → MacOS X
Summary: Conn: Mac OS X reads new resolv.conf after displaying DNS error. → Conn: Mac OS X - DNS failure or connection failure on auto-connect

Comment 2

16 years ago
cc'ing darin
(Reporter)

Comment 3

16 years ago
*** Bug 104857 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

16 years ago
More interesting:

Has problem: Mozilla, Netscape 7 PR 1, IE.

Works fine: Mail.app, Navigator (Chimera).
Whiteboard: notChimera
(Reporter)

Comment 5

16 years ago
*** Bug 104857 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

16 years ago
Blocks: 27975
(Reporter)

Comment 6

16 years ago
more keywords...
Keywords: mozilla1.2, topembed
(Reporter)

Comment 7

16 years ago
Mozilla 1.1 seems to return a "operation timed out while connecting to
<hostname>" if you try to connect and kick auto-dial. The second network
request, even hitting return, will work.

Updated

16 years ago
Keywords: topembed → topembed+

Comment 8

16 years ago
gordon
Assignee: new-network-bugs → gordon
(Assignee)

Comment 9

16 years ago
I've seen this problem on other platforms, and it happens in Netscape 4.x as
well.  The dial-up takes longer than various network timeouts (not necessarily
DNS) and so the operation fails.  It seems to be protocol dependent.  POP will
wait for the  dial-up, make a connection, and collect mail.  HTTP fails before
the dial-up finishes and returns an error.  Subsequent HTTP requests work once
the dial-up connection has been established.

I suspect this isn't a DNS bug.  I should add some logging to differentiate DNS
failures from protocol timeouts.
(Assignee)

Updated

15 years ago
Target Milestone: --- → mozilla1.3beta
(Reporter)

Comment 10

15 years ago
I think for Mac OS X, this is a CFM vs. Mach-O difference.
(Reporter)

Comment 11

15 years ago
RESOLVED/WFM:

Mozilla 1.1, Mozilla 1.3a, and Chimera 0.6 all work as desired now.

I've since upgraded to Mac OS X 10.2.3, so my suspicion is that Mac OS X 10.1.x
was not helping out w/ auto-dial correctly in all situations.

marcus: you filed he only dupe, can you see how this works for you now and
VERIFY or REOPEN based on your results?
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 12

15 years ago
I just tried this with Mozilla 1.3a and found the same situation exsists. Trying
to connect with the internet by launching Mozilla starts Mozilla but doesn't
retrieve the home page. I am using 10.1.5 however. This could have something to
do with this. PS I don't have permission to reopen this bug.
(Reporter)

Comment 13

15 years ago
Do you get the same error messages I described?

I'd like to open a new bug and have you put the OS version in the summary to
make it specific.
(Reporter)

Comment 14

15 years ago
VERIFIED: CFM is dead, Mach-O always worked.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.