Add mochitest tasks to CI

RESOLVED FIXED in Thunderbird 66.0

Status

enhancement
RESOLVED FIXED
6 months ago
3 months ago

People

(Reporter: darktrojan, Assigned: darktrojan)

Tracking

unspecified
Thunderbird 66.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

6 months ago
After bug 1506523, bug 1506706, and bug 1506715, we'll want to get these tests actually running.
Assignee

Comment 1

6 months ago
This is mostly ignorant copy-paste work. There's probably stuff I'm doing wrong, but it works:

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=77acd0b2cd48f9901fbfdd0a35a5d7f1c358c292

I also need to set some prefs before the tests run, but I don't know the best way to do it.
Attachment #9025183 - Flags: review?(rob)

Comment 2

6 months ago
Comment on attachment 9025183 [details] [diff] [review]
1507317-mochitest-ci-1.diff

Review of attachment 9025183 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good for now. I suspect that tests.yml will need some tweaking as Bug 1506715 gets finished up.
Attachment #9025183 - Flags: review?(rob) → review+
Assignee

Updated

6 months ago
Blocks: 1509246
Assignee

Comment 3

4 months ago

Closing this in favour of bug 1517298.

Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1517298

Comment 4

4 months ago
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/e5d328de82da
Prefs needed to make mochitests run correctly; rs=npotb
Assignee

Comment 5

4 months ago

This seemed like the right bug to label that change with.

Status: RESOLVED → REOPENED
Depends on: 1517298
Resolution: DUPLICATE → ---

Comment 6

4 months ago

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/1c11a287b639
Remove quotes from prefs in mochitest manifest; rs=npotb

Status: REOPENED → RESOLVED
Last Resolved: 4 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 66.0
You need to log in before you can comment on or make changes to this bug.