Closed Bug 1507344 Opened Last year Closed Last year

Move LLVM_PROFDATA merge step into a more convenient place

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(firefox66 fixed)

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: chmanchester, Assigned: chmanchester)

References

Details

Attachments

(2 files)

Right now this runs during the `maybe_clobber_profilebuild` step in the root Makefile.in. Merging the profile needs to happen in the second stage of the new PGO scheme so it would be more convenient to do this somewhere else, either as a part of a mozharness script or profileserver.py.
Note that we do currently use profileserver.py in the valgrind builds (just to have a fairly small test that actually runs Firefox).
Per bug 1507346 comment 2 we'll probably need to do this in the final build step since the tools we use are host binaries, so they won't run on macos, for example.
Also on Windows the re-build will need cygprofile.txt from the profiling step.
Assignee: nobody → cmanchester
Blocks: 1507334
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b1c7ad601ba
Add configure machinery for MOZ_PROFILE_USE and merging profile. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/df23b1fa16f5
Add a configure option for JARLOG_FILE in profile use builds. r=nalexander
https://hg.mozilla.org/mozilla-central/rev/3b1c7ad601ba
https://hg.mozilla.org/mozilla-central/rev/df23b1fa16f5
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Duplicate of this bug: 1507346
You need to log in before you can comment on or make changes to this bug.